I am running a Mac OS X Server 10.6.6 for a customer - and I rarely get physical access to it because the place is a residence and they don't want technicians there when the family is there, which is always... Recently, I have been getting this issue where both LogMeIn Free and APple Remote Desktop can't access the machine properly... I can get in via ssh, but I am not sure which process to kill to restore visual access. Whatever the issue is, it isn't limited to a single mode of access but affects both - almost as though the server all of a sudden realizes it has no monitor and therefore shouldn't have video...

The LogMeIn interface works fine - it just gives me a black screen. It goes through its motions and reports no errors, just the screen content is nothing but black.

ARD gives me a connection as well, but no window. In other words, I can hit the Control button with the machine in question selected, it supposedly opens the connection, reports no errors and even appears to be opening a window but it seems the window has dimensions 0 x 0 pixels and automatically closes - or simply doesn't display. If I access the Window menu, the machine in question is listed as having a window open although there is none.

Because this server handles the routing for the internal network and is also the gateway to the internet, I have to be extremely careful to make sure that it stays up or restarts cleanly or I have to go over there, which is not an option most of time.

Any input is much appreciated.

6 Answers 6

sudo ps auxwww | grep loginwindow | grep -v grep | awk '{print $2}' | xargs sudo kill -9

I wasn't able to locate a running loginwindow process when filtering down to the root user, the process was running under the user I was logged in as. Once I killed that process, everything was gravy.

  • If I read this correctly, it lists all running processes with extended attributes, selects the ones with loginwindow and within those the ones with root, then reverses the selection to all but those previously selected. If I understand the awk expression correctly, it will isolate the PID of selected processes. Those PIDs will be unconditionally killed. When I execute the command with xargs followed by less I get the PID of loginwindow and nothing else. That would kill any processes owned by any currently logged in user. I would like to figure out which process controls the video feed... Apr 2, 2011 at 15:46
  • The reason I am trying to isolate the single process or processes that control the video feed is because I have Windows XP running within vmware (owned by the logged in user) that controls the security cameras in the place. I would like to avoid abruptly killing that virtual Windows instance and having to reinstall that or reconfigure all the cameras and such. Apr 2, 2011 at 15:52
  • OK - I found the vmware unix command to suspend the virtual machine. Executed that and then your command. It did not kill all processes in the current user, it only put up the loginwindow without affecting the user processes. It did restore video. Thanks a million. Now I have to figure out why this black screen condition happens in the first place and how to make it not happen... Apr 2, 2011 at 16:16

If you boot a Mac headless (no monitor), the GPU kernel doesn't load because the OS assumes it isn't needed. This means that the remote machine has to use the CPU to render the desktop when you connect to it using ARD or similar (Logmein, Teamviewer etc). When the CPU is under heavy load, it struggles to render the remote desktop and you get screen corruption or even a black screen.

To resolve this, boot the remote machine with a monitor connector so the GPU Kernel loads. This takes the load from the CPU and prevents the black screen issue.

Alternatively, it is possible to create a dongle that fools the computer into thinking a monitor is connected. See https://macminicolo.net/blog/files/build-a-dummy-dongle-for-a-headless-mac-mini for more details.

Apple are fully aware of this issue but have yet to resolve it by allowing the graphics Kernel to load at boot without the presence of a monitor (like Windows can).


I wrestled with this for weeks before thinking to uninstall and reinstall on the Mac I was connecting to. Problem solved, screen saver still works etc.


I had this same problem connecting to a WinXP machine. I tried two different Macs (OS X 10.5 & 10.6) using Safari. LogMeIn said I was connected but the screen was black.

It turns out a security update disabled Java. To fix it, go into Safari's preferences and click on the Security icon at the top. Check off the Enable Java box and try LogMeIn again.


I don't have a black screen, but I do see horizontal black lines. Not sure why this happens. In any case, the easiest way to redraw after it happens is to set a hot corner for the screen saver, bring it up for a second, and then move your mouse to make it go away. The screen updates, your lines are gone.


The solution that worked in my instance was to go into the preferences of logmein itself and tell it to never lock the computer upon either disconnect or timeout. There seems to be some sort of a bug when you lock a Mac which is headless (has no monitor attached).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .