10

Can I set up KiTTY to send F7 press instead of bringing up Print dialogue when I press F7?

I make intense use of Midnight Commander and its editor, which both rely on F7 (to create a directory and to search through text) and I never actually print from a terminal.

3 Answers 3

13

According to http://www.9bis.net/kitty/index.php?action=forum&id=0144 just change print={F7} in the [Shortcuts] section of your config file to something else, e.g. print={SHIFT}{F7}.

6
  • 1
    I used to have print={SHIFT}{F7} and printall={F7} there. I've just removed both (as I NEVER print), but it didn't help. Printing still pops up on F7 :-(
    – Ivan
    Apr 2, 2011 at 7:15
  • 1
    I've replaced F7 with F12 then and this has solved the problem practically (so, I accept the answer as correct), but I'd prefer to remove this at all if possible.
    – Ivan
    Apr 2, 2011 at 7:19
  • 11
    I gave a few things a shot, and found that creating kitty.ini, in the location of kitty.exe, with the text: [KiTTY] shortcuts=no ...will also disable F7's action of printing.
    – stylez
    Apr 2, 2011 at 12:56
  • 4
    If you're looking for kitty.ini on Windows, I found mine in `C:\Users\...\AppData\Roaming\KiTTY`.
    – pattivacek
    May 8, 2014 at 17:10
  • 1
    To disable a shortcut I assign an empty value to it, printall=.
    – mortalis
    Feb 15, 2021 at 11:00
1

Right click / Shortcuts toggle - off will turn off shortcuts alltogether.

1

In my case it works something like this:

  1. Change to empty
    print=
    printall=
    But Kitty continues to use previous values ( {SHIFT}{F7} ,{F7} )
  2. Change to something else, for example:
    print={}
    printall={}
  3. Run Kitty and it works! F7 in mc shows "Create a new Directory" dialog

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .