5

I have a few XenServer VMs all running CentOS 5.5. Some are 32-bit and others are 64-bit.

Every time they boot, the following message appears:

Applying Intel CPU microcode update: [FAILED]

Does anyone know why this is happening and how I can fix it?

5

This probably happens because the OS is running inside a VM and therefore can't apply CPU microcode updates. As for how to fix it, I have no idea. Does this message prevent any meaningful work or does it merely disturb you? In the latter case you can safely ignore it.

  • This sounds very sensible, a virtual machine should neither need nor be able to apply microcode updates as that (I would have thought) should be handled by the host. – Mokubai Apr 2 '11 at 21:39
  • "As the virtual machine is running on virtual CPUs there is no point updating the microcode. Disabling the microcode update for your virtual machines will stop this error: " centos.org/docs/5/html/5.2/Virtualization/… – phuclv Jul 1 '15 at 4:43
4

If you want to prevent the Intel CPU microcode from starting at boot, you can disable it as follows: (Run the command as root)

# chkconfig microcode_ctl off

This will prevent the microcode service from trying to apply the update at boot, since it will fail on your VMs every time.

3

On a CentOS 6 installation, microcode_ctl doesn't seem to be invoked via the /etc/init.d (chkconfig) mechanism any more. I achieved the same effect by uninstalling the package:

# rpm --erase microcode_ctl

(I know the original question was centOS 5.5, but a search brought me here...)

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.