I am trying to use the jMonkeyPlatform to create a game, but the GUI of the application keeps flickering black on refreshes and resizes of the panels. I found issues on more programs that have this issue, but is there also an answer for this problem? Because I only found more problems and less solutions.

It is very frustrating to work with a flickering GUI. Does anyone has an answer to stop the flickering? I also tried to set my windows theme to Windows Basic, but that didn't work out either.

I already tried updating my java JRE, but the Java website says I have the latest already.
Installed programs:

  • Java (TM) 6 Update 24
  • Java (TM) 6 Update 24 (64-bit)
  • Java (TM) SE Development Kit 6 Update 24 (64-bit)

The jMonkeyPlatform is a 32-bit application. My computer is on Windows 7 x64.

I installed the Java (TM) SE Development Kit 6 Update 24 (32-bit) as well, but it didn't help. (I thought it did at first). I also found another application I'm using that is flickering as well (BrettspielWelt). Is there a possible answer for this?

BrettspielWelt flickering

I tried installing in different settings, but every setup fails in making black GUI's. I installed the following constructions:

  • 32-bit JDK and JRE
  • 64-bit JDK and JRE
  • 32-bit JDK and JRE and 64-bit JRE
  • 64-bit JDK and JRE and 32-bit JRE
  • 64-bit JDK and JRE and 32-bit JDK and JRE

So, that's actually every possibility and I even found out that my Control Panel/Java is flickering, because that is also built using Java.

I installed a new video card driver. But that doesn't solve it. This was something that I did change lately. I also tried the following combinations of installation without the JDK:

  • 32-bit JRE only
  • 32-bit JRE and 64-bit JRE
  • 64-bit JRE only

But that doesn't solve the problem either.


Try some of the Java 2D flags, in particular ddoffscreen and if that doesn't work, noddraw:

java -Dsun.java2d.ddoffscreen=false -jar whatever.jar

Somehow, I managed to fix it by reinstalling my ATI Radeon HD 4900, but this time without some SDK and without the catalyst control center.

Still testing...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.