Last night, pragmatist Vaio Care automatically fixed (!) the errors on my Sony Vaio laptop and soon afterward, a big problem emerged. I start Firefox 3.6.16 and navigate to superuser.com (and other Stack Exchange sites) and the following warning appears:

Super User works best with jQuery enabled

What did I try to fix it? Well, here is the list:

  • As I suspect Vaio Care 99%, I loaded the previous Windows restore point (yesterday, just before Vaio Care started its job). It loaded the registry to its previous state as well. Result: I got the same jQuery warning.

  • I checked Firefox' settings. JavaScript was enabled. I disabled/re-enabled it, restarted FF. No good.

  • I updated Java from Oracle's site to the latest version (6.0.24). No good.

  • I started Firefox in the Safe Mode. No good.

  • I uninstalled and reinstalled Firefox completely. No good.

  • I shut down the Windows Firewall. No good.

  • I checked Internet Explorer 9 if it works. IE9 works fine with jQuery. The problem seems to be related to Firefox probably (I'm not sure though).

So I spent all of my bullets. What should I do now to fix this?

  • 1
    @Mehper my guess would be that there is some sort of security setting in FF that is blocking the jquery download. But I'm not aware of how to fix it, if that is the problem
    – Patrick
    Apr 5 '11 at 15:43
  • It just happened yesterday. I did not update Windows, Firefox or any other programs. I did not change any settings on my PC. I suspected AdBlock but even when it's off, the problem continues. Apr 5 '11 at 15:46
  • 2
    Does the jQuery .js file (the one specifically used by Super User) download at least in Firefox? ajax.googleapis.com/ajax/libs/jquery/1.5.1/jquery.min.js
    – Gaff
    Apr 5 '11 at 16:16
  • @Gareth: No. Moreover, I cannot view YouTube videos, write comments on Facebook, etc. IE9 works fine. Apr 5 '11 at 16:47
  • I uninstalled Java and then reinstalled it. I restarted my machine and click on the link @Gareth gave, and it opened this time. Then I tried Super User, and it worked. I don't know if uninstalling & reinstalling Java really helped. Then why couldn't I open jquery.min.js? Could it be related to something about googleapis server? If yes, why was IE9 working whereas FF does not? I'll really appreciate if somebody can shed light on this. Apr 5 '11 at 17:03

I've just had the same problem on Linux, with Firefox 3.6, and solved it. I had just to force Firefox to redownload jQuery. Specifically, I clicked on the link given by Garreth, got an error from Firefox (something like "can't access the file", but from firefox) and pressed Shift-F5 (force reload) or maybe F5 (Shift-F5 is safer). The file was loaded, and Super User started working again. The poster did a similar step, among other things.

Gareth wrote:

Does the jQuery .js file (the one specifically used by Super User) download at least in Firefox? ajax.googleapis.com/ajax/libs/jquery/1.5.1/jquery.min.js


You could try backing up and deleting your user profile. Go to Start -> Run and type in %APPDATA%\Mozilla\Firefox\Profiles

And click OK

Find the folder that ends with .default and copy it to someplace else, and then delete the folder in the Profiles directory.

When you start Firefox again, you should end up with a new profile. Try navigating to a Stack Exchange site and see if you get the same warning message. If it works, then something was wrong with your previous profile. If you get the same problem, simply move your profile copy back into Profiles.

  • I did it but it didn't work. I restored my profile back. Apr 5 '11 at 16:05


This is the link that superuser.com uses for jQuery. Do you have an antivirus or something that blocks googleapis.com? Is there some kind of setting that only allows scripts to be downloaded from the same site (superuser.com). I know that AJAX calls have a 'same origin policy'.

Also, what add-ons are you using? Perhaps you could try disabling all add-ons and try accessing superuser.com again. Maybe some plugins are conflicting with it.

If you're using FF 4, it seems that others have this problem too.

Anyway, it looks like your problem was solved, but these are just ideas as to why it didn't work.

  • If you read my question well, I state that I started Firefox in the Safe Mode, which means all addons are disabled. I also cleared my profile and retried. Please read the whole post. Nothing was changed on the machine since yesterday except whatever Vaio Care did. Apr 5 '11 at 17:48
  • Did you remove all of the files associated with FF when you reinstalled it? Sometimes there's lingering data after you reinstall. Also, did you reinstall FF 3.6 or did you install FF 4?
    – beatgammit
    Apr 5 '11 at 17:53
  • Sure. I removed everything before reinstallation. I installed 3.6.16. I don't use FF4. Apr 5 '11 at 18:12
  • I dunno, that's a really odd issue then... I've never had issues with FF 3.6 (we used it at my old work almost exclusively).
    – beatgammit
    Apr 5 '11 at 18:17

This is what i did. Goto Options>Security, if the "Warn me when sites try to install add-ons" check box is selected goto the "Exceptions" and add "http://ajax.googleapis.com/". Refreshed my browser and it's fixed. BTW, i'm using Firefox 4.


Reset Firefox preferences to troubleshoot and fix problems


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.