Whenever I type "a" in Terminal, I get a beep, and no output. If in uppercase, "A" types fine. This computer (new mac mini) is only a few days old, but I've done a few things that may have caused this behavior:

1) Installed DoubleCommand. Disabling all options in DoubleCommand doesn't help

2) Change some of the keyboard shortcuts in Terminal (specifically: Home, PgUp, PgDn, End, shift+PgUp, shift+PgDn). Switching to a different theme (where my keyboard shortcut changes don't exist) does not help.

What I haven't tried:

1) restart (Update2: tried, didn't help)

2) uninstalling DoubleCommand (Update 2: tried, didn't help)

lowercase "a" works in Vim, but just not at command prompt

  • 1
    Any changes to your .inputrc, .bash_profile? Do you run screen or tmux? Also, seriously? You take the time to post and explain your issue and expect others to answer, but don't restart your machine? This is number 1 troubleshooting advice for a reason. – Daniel Beck Apr 6 '11 at 6:47
  • @Daniel: I thought I cleared out my .bash_profile and .inputrc, but did so again to be sure, and presto, this fixed my issue! Much thanks.. Can I accept your comment as the answer? – Dolan Antenucci Apr 6 '11 at 6:52
  • You can't unless he reposts it as an answer. – Sophie Alpert Apr 6 '11 at 6:53
  • Now you can :-) I don't like posting troubleshooting suggestions as questions. Thanks in advance! – Daniel Beck Apr 6 '11 at 6:54

Check to see if there's anything odd in your .inputrc or .bash_profile. Best to move them to a different folder temporarily and see if the problem goes away.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.