3

I am using Kde 4.5 in Debian and I get some notifications after start that I need to update something. How can I disable it (I often don't want to waste bandwidth for such things)?

I am using Debian Wheezy and Kde 4.5

3

Open the KDE System Settings application. (I find the easiest way is to press Alt+F2, type in systemsettings, and press Enter. But you can also launch it from the K menu if you like.)

Choose Software Management under System Administration:

systemsettings System Administration section with Software Management highlighted

Then select Settings from the left panel, and under Check for updates, choose Never:

Settings panel from Software Management KCM applet

Finally, click Apply. KPackageKit will no longer bother you about updates. But, remember to use apt-get or your favorite package manager to download updates periodically so you aren't exposed to security vulnerabilities.

5
  • 2
    Hi, I am now trying to find these settings on my laptop, but I don't have software management in the settings at all (running Debian testing). Any idea how to install it?
    – Grzenio
    Jun 9 '11 at 9:41
  • @Grzenio: I believe it's part of the kpackagekit package but I can't check right now. I'm not sure how you have the component that notifies you about updates but not the configuration for it, though. Try running kcmshell4 kpk_settings to launch it manually.
    – Patches
    Jun 9 '11 at 10:32
  • I can't run it: Could not find module 'kpk_settings'., and I can't find the kpackagekit package :(. Looks like Debian maintainers did something weird.
    – Grzenio
    Jun 9 '11 at 10:40
  • 1
    @Grzenio: Yeah, it looks like they're moving away from PackageKit in wheezy. Instead, you can remove the update-notifier-kde package altogether or just disable it by removing its .desktop file from /usr/share/kde4/services/kded/.
    – Patches
    Jun 9 '11 at 21:00
  • 3
    Package 'update-notifier-kde' is not installed, so not removed - any updates on how to do this in Plasma 5?
    – Xerus
    Sep 7 '18 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.