4

OS X / Apple keyboards offer these handy keyboard shortcuts for funky Unicode characters, like + . gives an ellipsis character (). How can I use these inside iTerm2.app? Whenever the key is pressed in combination with another key it seems to trigger an error (with a sound and everything)

I found this in the iTerm 2 FAQ:

Q: How do I make the option/alt key act like Meta or send escape codes?
A: Go to Preferences → Bookmark tab. Select your bookmark on the left, and then open the Keyboard tab. At the bottom is a set of buttons that lets you select the behavior of the Option key. For many users esc+ will be the best choice.

So I went to Preferences → Profiles → [My Profile] → Keyboard and there I changed the bottom two options to “+esc” instead of “normal” (the default).

Preferences → My Profile → Keyboard

But even then, I cannot type special characters using key combinations with the key.

There’s also a Keyboard section in the Preferences, looking like this:

http://i.stack.imgur.com/OAZWk.png

Would I have to change anything there?

P.S. Note that this works out-of-the-box in OS X’s Terminal.app.

2
  • The instruction are on how to use Option as an escape key, e.g. like Control. You don't want that.
    – Daniel Beck
    Apr 7, 2011 at 7:43
  • @Daniel: Thanks. No matter which of the settings I try in that first screenshot, it doesn’t seem to do what I’m after. Apr 7, 2011 at 8:05

1 Answer 1

6

To fix iTerm 2's behavior, go to Preferences > Profiles > Keys and set the left (and/or right) Option key to act as "Normal":

Screenshot

That way you'll be able to enter key combinations for umlauts, accents, etc.

If you have several profiles defined, you'll have to make the change for each one.

2
  • Bizarrely, if option and command have been swapped with each other in the Mac's system preferences (i.e. option keys are now command keys and command keys are now option keys), these settings seem to operate back to front. That is, the "left option" setting controls the right option key and the "right option" setting controls the left option key.
    – Weeble
    Mar 31, 2020 at 13:55
  • 1
    Doesn't work for me, that's just the default settings. Any combination with option key prints "[D".
    – Oli Crt
    Apr 1, 2020 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.