The bug is well documented in the apple forums with a possible workaround:


In a few words my Mac mini's keyboard will stop responding randomly when switching spaces and the spaces overlay stays on the screen but I can still change spaces with the keyboard shortcuts and put it into sleep mode. To workaround it I have to put the Mac to sleep mode and then wake it up again. Does anyone know of an actual solution to the problem instead of the workaround?

  • The bug is still open with Apple and I'm afraid they won't fix it for 10.6 anymore. What sometimes helps is to keep the modifier keys used for the Spaces-Switching-Shortcut pressed for a second or two, then release them and the overlay panel should go away. – MacLemon May 5 '11 at 11:29

In activity Monitor quit the process called Dock. you will get a gray screen for 1 or 2 seconds and then it turns back on. After that you can switch between spaces again.

Hope this helps


Not really a fix, but here's some random(ish) things you can try off the top of my head. Hope this helps you out:

  1. Make sure all OSX system updates are installed. (especially any keyboard firmware updates, if they have them).

  2. Disassociate your keyboard from the machine. Remove the Bluetooth profile for it in System Preferences.

  3. Switch spaces off (or down to a single space if you can't disable them).

  4. Throw down an extra-paranoid reboot while you're at it (getting silly, I know, but can't hurt, right?).

  5. Re-associate the keyboard, reactive spaces and test.

If the problem's still there, perhaps try alternate keyboard layouts - this could be ultra annoying, but that'd sure be interesting if that helped.

Submit a bug report to Apple if any of this stuff works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.