1

Yesterday I installed OpenOffice on my Linux server. But when I go to run it through the command line, it says command cannot be found. I've also tried other things like OOWriter, etc. Has anyone had this problem? Installation process went like below:

    root@aserver [OOO330_m20_native_packed-1_en-US.9567/RPMS]#
    rpm -i *.rpm 
        package openoffice.org-ure-1.7.0-9567.i586 is already installed
        package ooobasis3.3-core01-3.3.0-9567.i586 is already installed
        package ooobasis3.3-en-US-3.3.0-9567.i586 is already installed
        package ooobasis3.3-core02-3.3.0-9567.i586 is already installed
        package ooobasis3.3-core03-3.3.0-9567.i586 is already installed
        package ooobasis3.3-core04-3.3.0-9567.i586 is already installed
        package ooobasis3.3-core05-3.3.0-9567.i586 is already installed
        package ooobasis3.3-core06-3.3.0-9567.i586 is already installed
        package ooobasis3.3-core07-3.3.0-9567.i586 is already installed
        package ooobasis3.3-en-US-base-3.3.0-9567.i586 is already installed
        package ooobasis3.3-en-US-calc-3.3.0-9567.i586 is already installed
        package ooobasis3.3-en-US-draw-3.3.0-9567.i586 is already installed
        package ooobasis3.3-en-US-help-3.3.0-9567.i586 is already installed
        package ooobasis3.3-en-US-impress-3.3.0-9567.i586 is already installed
        package ooobasis3.3-en-US-math-3.3.0-9567.i586 is already installed
        package ooobasis3.3-en-US-res-3.3.0-9567.i586 is already installed
        package ooobasis3.3-en-US-writer-3.3.0-9567.i586 is already installed
        package ooobasis3.3-base-3.3.0-9567.i586 is already installed
        package ooobasis3.3-calc-3.3.0-9567.i586 is already installed
        package ooobasis3.3-draw-3.3.0-9567.i586 is already installed
        package ooobasis3.3-images-3.3.0-9567.i586 is already installed
        package openoffice.org3-3.3.0-9567.i586 is already installed
        package ooobasis3.3-impress-3.3.0-9567.i586 is already installed
        package ooobasis3.3-math-3.3.0-9567.i586 is already installed
        package ooobasis3.3-writer-3.3.0-9567.i586 is already installed
        package jre-1.6.0_22-fcs.i586 is already installed
        package ooobasis3.3-binfilter-3.3.0-9567.i586 is already installed
        package ooobasis3.3-en-US-binfilter-3.3.0-9567.i586 is already installed
        package ooobasis3.3-gnome-integration-3.3.0-9567.i586 is already installed
        package ooobasis3.3-graphicfilter-3.3.0-9567.i586 is already installed
        package ooobasis3.3-javafilter-3.3.0-9567.i586 is already installed
        package ooobasis3.3-kde-integration-3.3.0-9567.i586 is already installed
        package ooobasis3.3-onlineupdate-3.3.0-9567.i586 is already installed
        package ooobasis3.3-ooofonts-3.3.0-9567.i586 is already installed
        package ooobasis3.3-oooimprovement-3.3.0-9567.i586 is already installed
        package ooobasis3.3-ooolinguistic-3.3.0-9567.i586 is already installed
        package ooobasis3.3-pyuno-3.3.0-9567.i586 is already installed
        package ooobasis3.3-testtool-3.3.0-9567.i586 is already installed
        package ooobasis3.3-xsltfilter-3.3.0-9567.i586 is already installed
        package openoffice.org3-base-3.3.0-9567.i586 is already installed
        package openoffice.org3-calc-3.3.0-9567.i586 is already installed
        package openoffice.org3-dict-en-3.3.0-9567.i586 is already installed
        package openoffice.org3-dict-es-3.3.0-9567.i586 is already installed
        package openoffice.org3-dict-fr-3.3.0-9567.i586 is already installed
        package openoffice.org3-draw-3.3.0-9567.i586 is already installed
        package openoffice.org3-en-US-3.3.0-9567.i586 is already installed
        package openoffice.org3-impress-3.3.0-9567.i586 is already installed
        package openoffice.org3-math-3.3.0-9567.i586 is already installed
        package openoffice.org3-writer-3.3.0-9567.i586 is already installed
    root@aserver [OOO330_m20_native_p

acked-1_en-US.9567/RPMS]# soffice
bash: soffice: command not found
1
  • rpm -ql openoffice.org3-3.3.0-9567.i586 or so..
    – tmg
    Apr 7, 2011 at 13:16

2 Answers 2

0

The binary name is ooffice, not soffice:

$ ooffice
0

It's soffice but you need to be in the correct path or set your environment point to it. The default install location is /opt/openoffice.org3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.