Whenever I access my Windows 7 (Professional, 64-bit) desktop through a VNC client (TightVNC on laptop or VNC Viewer on iPhone), Windows pops up the "Windows has detected your computer's performance is slow" message in the notification area. This is fine and easy enough to dismiss, but it's rather annoying having to change the theme back from Windows Basic every time I log in remotely.

The computer is very well maintained (defragged, anti-spyware, up to date, not pirated, etc.), plenty fast, and is only being detected as slow because it's being accessed by a VNC client. I've checked the memory and CPU usage while logged in remotely and it's completely normal.

Is there any way to disable this notification or (more preferably) not have Windows automatically change the theme? I appreciate the notification, but the computer is running fine Mr. Clippy ;)

  • What happens if you run the Windows Experience Index while connected via VNC? Which VNC server are you using? Any particular reason you're using VNC instead of an RDP client?
    – Bacon Bits
    Apr 10, 2011 at 2:17
  • Haven't tried running WEI while connected, will try it. I'm using TightVNC and the only reason I'm not using RDP is because I frequently access it via iPhone and have not found a suitable RDP client for it. Apr 26, 2011 at 2:50
  • Same windows experience index whether using VNC or not Apr 26, 2011 at 3:00

3 Answers 3


I have has this problem as well and i just been, looking around and i found out that when the message pops up click on the little spanner next to the cross sign and look down until it says "Desktop Windows Management" and then under that go onto the drop down and select "Hide Notifications and Icon," then this will stop the message from popping up. Hope this helps.


If I'm not mistaken, the notifications originate from the Windows "Action Center". You can disable all notifications from the Action Center by doing the following:

  1. Click on the little arrow that says "Show hidden icons". This icon resides in the Win7 taskbar (to the left of the system clock).

  2. Click the blue "Customize..." link

  3. The "Notification Area Icons" window will pop up.

  4. Scroll down until you see the list item labeled "Action Center". The icon for it is a little white flag.

  5. There should be a drop-down list to the right of the "Action Center" label/description. Click on that to see the options.

  6. Make sure you click on the "Hide Icon and Notifications" option. You will not see any more notifications from the Action Center again.

Hope this helps! :)

  • I don't want to disable all notifications, or even necessarily this one. I just want windows to stop changing my theme to Windows Basic when I log in with VNC. I couldn't care less if it gives me a notification as long as it stops changing the theme Apr 26, 2011 at 2:51
  • Just realized the question wasn't as clear as it could have been, ideally I'd like to still receive notifications from the action center when virus scan is off or there's new updates, etc. Apr 26, 2011 at 3:00

This is in regards to the notification pop-up from RDP from iPhone.

I'm doing a huge amount of high-end graphics/image processes - and that notice has been constantly popping up every hour.

When I selected 'hide icon and notifications' (for "Action Center" as suggested above) does that alert STILL pop-up. ... I just realized, in MY situation, there is a different notification to alter to get rid of that pop-up. On my Win7Ult, it's 'Desktop Manager" that's giving me that irritating error. Having turned that off, that is 'Hide Notifications" for me anyway, did the trick.

RE: RDP for iPHone

There is a 'free!' app called 'RDP Light' from 'Mocha' - I've been using that for over a year now, and I've not found ANYTHING that I cannot do (so far!) that I can do as if I was logged directly into the Windows console.

Hope that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.