I have copied some files from an XP computer to a PC running Windows 7. I am logged on as a user who is marked as an Administrator.

When I try to access the directory, I am told I don't have permission. Understandable, but what is odd is that I as an administrator don't have access to take ownership of the files. I don't have permission to add users in the ACL or to take ownership, indeed such options are greyed out.

Why as an administrator user can I not take ownership of files?

  • You don't even have the option to take ownership and then change permissions?? – nhinkle Apr 7 '11 at 22:35
  • This happened to me once on XP, but was easily fixed by a reboot. I don't know why, it doesn't make any sense, but maybe this could work for you, too? – Kromey Apr 7 '11 at 22:40
  • No, it's greyed out where I would select/search for users... – Sonny Ordell Apr 7 '11 at 22:41
  • it is possible to (un)intentionally mark yourself as having no access to a file or folder. in this case you might try having another administrator try taking ownership and then see if they can grant you access to it – Xantec Apr 7 '11 at 22:42

Try opening an elevated CMD window (right click> Run as Administrator) and type:

Net user administrator /active:yes

Confirm the command ran successfully then log off and log back in as the administrator account. After logging in as the built-in administrator account you should be able to take ownership.

Do not use this account for anything other than troubleshooting, never for everyday use.

If you wish To disable the account:

Net user administrator /active:no

  • Ah, this didn't work. I still don't have permission and the options are still greyed out as per my normal user account (which is also an Administrator). – Sonny Ordell Apr 8 '11 at 0:53
  • @sonny you are still unable to take ownership? – Not Kyle stop stalking me Apr 8 '11 at 1:46
  • Yes, I just get that I don't have permission to do this. Oddly enough even on the XP computer I get the same error with the XP administrator account. – Sonny Ordell Apr 8 '11 at 2:37
  • That's very odd @sonny, I had the same problem when I first migrating to windows 7 and it worked for me. I can't think of what else could be causing it unless you used, deny permissions but even then you should be able to take ownership. – Not Kyle stop stalking me Apr 8 '11 at 13:52
  • Oh yeah thanks @moab for the edit extremely valid point... in terms of UAC that would be like running as root. – Not Kyle stop stalking me Apr 8 '11 at 13:52

I had the same problem with my Windows 7 64-bit. I was finally able to do it as mentioned above by running Command Prompt as Administrator and then executing the following Batch File from the Dos Shell.

SET DIRECTORY_NAME="C:\Windows.old.000"
ICACLS %DIRECTORY_NAME% /grant administrators:F /t

Replace DIRECTORY_NAME with your directory you want to delete. This way you don't have to logout and come back in as a real Administrator instead of your normal login with Administrator "rights".

I do agree as mentioned above that one should not do everyday work as an Administrator.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.