0

I've installed CentOS 5.5 64-bit on an external WD 500GB HDD. I went through the installation setup, and formatted the external HDD normally. (100M /boot, 250GB /, 248GB /tmp , 2.8GB swap). I also installed grub in the external HDD's MBR.

After installation, I could boot up Linux on the same platform (Arrandale). However, as soon as I took it to a different platform such as Atom Pineview D525, it had all kind of problem on Grub, such as Grub Hard Disk Error, or it just hanged on grub loading stage {1.5,2}. Sometimes, if I'm lucky, I would get to grub command prompt, but rarely I could boot up. I would stuck at mounting file system.

I've searching a lot on Google, and people suggested to reinstall Grub, so I tried various method to reinstall Grub, but the same behaviors still exist. I can't guarantee the drive will boot...

  • By the way, this was all with grub legacy (0.97.63?) If people think grub 2 has significant improvement on usb boot, please comment below. I will give it a shot, but I don't want to mess with grub2 if it's not worthy the time... – Patrick Apr 8 '11 at 14:29
1

I'm not sure if you solved this issue; I had a similar problem to you. After updating the BIOS, Linux can now boot from a USB drive.

I used the following BIOS:

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20077&keyword=MW0083P.BIO&DownloadType=BIOS&lang=eng

|improve this answer|||||
0

Have you tried Plop? It's probably the most versatile boot loader around and is ideal for use with USB devices.

|improve this answer|||||
  • Thanks, I will definitely check it out! Will get back to my experience once I try it today. – Patrick Apr 8 '11 at 17:11
  • I tried the Plop. Unfortunately, it didn't even detect my USB drive... – Patrick Apr 9 '11 at 22:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.