5

I've just finished installing Internet Explorer 9 on my Windows 7 32-bit machine. It appeared to complete okay, with no errors or warnings in the event logs.

However when I try to run Internet Explorer 9, the window opens, the blue loading circle spins, "not responding" appears, then the window shuts without anything appearing in the browser window.

My machine is a decent spec, and I've had no problems with Internet Explorer 8, or any other browser before.

Here are the things I've tried which didn't help:

  • Installing Internet Explorer 9 via Windows Update, instead of manually
  • Running in "no add-ons" mode
  • Disabling all add-ons manually
  • Running the OS in safe mode
  • Temporarily disabling firewall/antivirus
  • Resetting Internet Explorer settings in "Internet Properties"
  • Ticking "Use software rendering instead of GPU rendering" in "Internet Properties"
  • Re-registering dlls
  • Running program as administrator
  • Installing Service Pack 1
  • Installing all critical/important Windows updates
  • Logging into Windows as different user
  • Downloading the installer using a different machine (in case installer was corrupt)

I am now officially out of ideas. Anyone have any more?

UPDATE Ok. It looks like we might be getting somewhere. I have run procmon, as suggested by ccpizza. Here's the result when I try running IE9. It's full of "Name not found" and "Path not found" errors. Why they're happening- I don't know.

16
  • tough, hope you can find a better solution than reinstall the operating system...
    – Bolu
    Commented Apr 8, 2011 at 15:24
  • BTW: have you installed all the updates for your system?
    – Bolu
    Commented Apr 8, 2011 at 15:31
  • 5
    Install Chrome ;->
    – Moab
    Commented Apr 8, 2011 at 16:37
  • Have you tried using it from another user account, or the hidden Administrator account?
    – Moab
    Commented Apr 8, 2011 at 16:38
  • 1
    See this topic...stackoverflow.com/questions/1444760/…
    – Moab
    Commented Apr 18, 2011 at 14:23

7 Answers 7

2

This not the first such question I am answering here. Internet Explorer 9 seems to be unable to install itself on some computers.

Seeing the number and variety of attempts that you have already done, there is not much left. "Use Software Rendering" is almost always cited as the reason for startup crashes, but you have tried it already, but better keep it checked for future tests, as well as using no add-ons.

EDIT: See this Microsoft article: How to solve Internet Explorer 9 installation problems.

Questions:

  1. Did you look into the Windows 7 Event Viewer?
    An error entry there from when it crashed might point us in the right direction.
  2. Did you specify any non-standard paths when installing Internet Explorer 9?

If a cause cannot be found, then the only solution would be to uninstall Internet Explorer 9 and wait for the service pack.

7
  • 1) There were no errors in the event viewer during the install (but then that bit didn't actually fail). I can't find any mentions of a crash- where would they be? 2) No, I used the default paths throughout the install.
    – Urbycoz
    Commented Apr 18, 2011 at 9:23
  • Search for events from when you try to start IE9 and it closed/crashed. Logically they should be in the Event Viewer in "Applications and Services Logs -> Internet Explorer", but search in all the branches for errors or warnings from that time.
    – harrymc
    Commented Apr 18, 2011 at 9:34
  • 1
    The "Internet Explorer" log was completely empty. Nothing of note in any of the other logs either, I'm afraid. Would you expect there to be some kind of "information" message somewhere if it succeeded? Couldn't see one of those either.
    – Urbycoz
    Commented Apr 18, 2011 at 9:49
  • 1
    (1) Yes, it still fails. (2) Eset NOD32 antivirus. I'd be surprised if that's to blame though, since several of my colleagues use it and IE9 is ok for them.
    – Urbycoz
    Commented Apr 18, 2011 at 11:17
  • 1
    (It is good practice to disable the antivirus when installing a monster such as IE9 that affects all of Windows.) My private theory is that something went wrong in the past with Windows Update that causes the IE9 installation to fail. Unfortunately, the only way to test it is a clean install of 7. I have added a link to my answer which may be the last chance, apart from hoping that IE9 SP1 may solve the problem.
    – harrymc
    Commented Apr 18, 2011 at 11:52
2

I would try starting it under Procmon (it combines several utilities that were previously called FileMon, Regmon, now owned by Microsoft). It helped me in many cases figure out the real cause of the problem.

2
  • Ok. Here's the result when I try running IE9: box.net/shared/xl83eoxd7y It's full of "Name not found" and "Path not found" errors. Why they're happening- I don't know.
    – Urbycoz
    Commented Apr 21, 2011 at 7:35
  • You should post the entire log... having thousands of errors is normal, so people would need to be able to find the correct ones.
    – user541686
    Commented Apr 21, 2011 at 9:45
2

I would also suggest doing a Windows Update, making sure that you have Service Pack 1, then seeing if Internet Explorer 9 will work following that.

1
  • Good thought. After my first failed attempt I checked and found I didn't have SP1. So I uninstalled IE9,installed SP1 then reinstalled IE9, hoping this would fix it. Sadly it didn't.
    – Urbycoz
    Commented Apr 11, 2011 at 7:15
1

I just solved the same problem. It turned out that I had a copy of IE8 left in c:\program files, while IE9 was installed to d:\program files, where my default program files folder is.

Once I replaced c:\program files\internet explorer with d:\program files\internet explorer, it started working.

0

Uninstall Internet Explorer 9, reboot, run CCleaner and remove any temporary files, reboot, download Internet Explorer and install by using "Run as Administrator".

1
  • I've done all of those except running ccleaner.
    – Urbycoz
    Commented Apr 18, 2011 at 15:06
0

Did you try starting Internet Explorer in safe mode?

Start > Run >iexplore -extoff
1
  • Yes, I did. No difference at all.
    – Urbycoz
    Commented Apr 19, 2011 at 10:44
0

Maybe try installing DirectX again?

3
  • Nice thought. Tried but no difference.
    – Urbycoz
    Commented Apr 21, 2011 at 7:19
  • @soandos: It's a download link. I can hardly summarize it.
    – Ry-
    Commented Jul 16, 2012 at 3:21
  • @minitech, apologies, was on autopilot
    – soandos
    Commented Jul 16, 2012 at 3:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .