When I try to ping my server from somewhere other than my local network, if finds the host, but returns as a lost packet.

Screenshot from http://tools.pingdom.com: http://cl.ly/1I1c3K0z3Y1I2c3x3R3Z

I have my server plugged into a Linksys WRT610N router, and when I bypassed the router and went strait to the server the ping worked perfectly.

So, the problem lies with the Linksys router, but I cannot find anything that would fix it. I have DMZ set to forward everything to my server.

Anyone know how to fix this?

2 Answers 2


According to this reply in the Linksys UK forum, all you need to do is to Uncheck Filter Anonymous Internet Requests.


enter image description here


Source of screenshot

  • I tried that earlier, and it doesn't work. Thanks though!
    – sman591
    Apr 19, 2011 at 3:32

AFAIK Linksys's are blocking ICMP requests by default, anyway You can disable it in some of models

  • Do you know of a suitable router that doesn't block them?
    – sman591
    Apr 10, 2011 at 21:33
  • Euhm... No... Linksys does not block ICMP by default... Apr 10, 2011 at 21:44
  • @TiZion Linksys does for this router evidently
    – sman591
    Apr 19, 2011 at 3:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .