A client uses Remote Desktop (MSTSC) to connect to her office. Recently her network admin apparently did some sort of update on the server (Windows Server 2008), and after these every time she connects with local printing enabled MSTSC crashes. If printing is disabled then it works fine.

Her machine is running XP Media Center Edition SP3 (32 bit). I've updated Remote Desktop to the latest version to no avail. I've also uninstalled/reinstalled her printer drivers, also with no effect.


  • Have you spoken to the Network Admin to figure out what was changed? Apr 11, 2011 at 13:21
  • They apparently just updated the MSTSC client on the server's end and did some Windows Updates.
    – Sootah
    Apr 23, 2011 at 1:19

1 Answer 1


Figured it out! It was actually the Dell AIO 926 printer driver that was causing the problem. I was so focused on the Brother MFC 8860DN (because that's her primary printer, and the one she uses for work) that I hadn't even considered the fact that ALL printers were being redirected.

The solution was actually pretty simple. While there I ran Windows Update on her machine and WU detected (somehow) that there was a problem with the Dell driver. I let it fix that, as well as run the other updates and voilà! it works now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.