I have many PCs & Macs in my household...all of them connected to a Windows 7 share.

All of a sudden, one of my Windows 7 PCs can't connect to the share anymore. In fact, it can't connect to any computers on the network. The network drive can't be found. Oddly enough, the server is visible in the Network sidebar from Windows Explorer. However, clicking it displays an error dialog (the specified network provider name is invalid)

What is even more odd is I can ping the server (using either the machine name or ip address) and it finds it just fine. But any attempt to reconnect to the server fails via `net use' or manually Windows Explorer.

I've flushed the DNS cache, but that didn't fix the problem.

I'm at a loss on what else I can try...can somebody offer some insight?


Any updates on that machine lately? I have seen the "advanced sharing options" get reset before. Or perhaps Windows no longer thinks it's on your home network or that it's a public network. Goto the "Network and Sharing Center" and see if the network is identified as a "home" network. Then check out the "advanced sharing options" and see if "network discovery" is turned on. Other than that, could be a firewall issue. I recommend checking out the "event log" and see if there are any network related errors.

You could also create a share on the broken machine and see if it is visible to the other computers, it might help point you in the right direction.

Hope that helps.

  • ok...I read the event logs and it says that The Computer Browser service depends on LanmanServer. I tried to manually start Computer Browser in the Services but it failed. So apparently I lost LanmanServer somewhere...
    – Tim Reddy
    Apr 12 '11 at 1:15
  • I couldn't figure it out...considering this PC is my wife's internet PC, I just reinstalled Windows 7...it took less time to do that than figure out this problem...
    – Tim Reddy
    Apr 12 '11 at 4:34

In control panel go to Network and Sharing Center, once it opens click "Change Adapter Settings" on the left side, what do you see in there?

You network adapter that is being used to connect to the network should show in here, it will be either Wired or Wireless, let me know if you see multiple adapters for either wired or wireless before you continue below.

Go to the toolbar > Advanced > Advanced Settings, a small window will open, select your adapter currently being used to connect to the network in the top pane, then be sure your bindings for File and Printer Sharing and Client for Microsoft networks boxes are all checked, if not check them and hit OK, close the window.

If any boxes were Not checked and you checked them, reboot the PC and try to connect to the network.

. enter image description here


I had this same issue. Symptoms were I could see the systems inside the Network list in Explorer, but when ever I tried to connect to one I was given a "The specified network provider name is invalid" error.

My own laptop was in there and gave the same error.

Because Peer Networking Grouping service would not start, I deleted the contents of %windir%\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking

The error I got was The Peer Networking Grouping service depends on the Peer Name Resolution Protocol service which failed to start because of the following error: %%-2140993535

Then I started the services: Peer Name Resolution Protocol, Peer Networking Grouping, Peer Networking Identity Manager

Then I needed to uninstall Client for Microsoft Networks from my primary network adapter, reboot, and reinstall it.

Everything works as expected now.


Well, I have to record this here as it was a strange one. I found my fix here: https://www.megaleecher.net/Fix_Windows_Cannot_Access_Error. In my case, a disk recovery program, Diskinternals EFS Recovery, had replaced the "ProviderOrder" entry under registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order with the value "cbfsconnect2017-0". Once I put back the Windows default, "RDPNP,LanmanWorkstation,webclient" things immediately started working again (without a reboot unlike what that post says, but no guarantees - you may have to reboot).

The really strange thing was that I could do a "Start, Run" and connect to any folder that was at least two folders deep (It would auto complete folder names as I typed \\ServerName\etc.). E.g. I could connect to \\ServerName\ShareName\Subfolder but not \\ServerName or \\ServerName\ShareName) and when I viewed the address bar in Windows File Explorer, it looked like "> Network > ServerName > \\ServerName\ShareName > FolderName" (yes, with the slashes) instead of "> Network > ServerName > ShareName > FolderName"

When I clicked to the right of the address (to copy it out) it showed as "\\ServerName\ShareName\Subfolder". Once I got to the subfolder I could then navigate up a folder to the root share (either with Alt+Up Arrow or clicking "\\ServerName\ShareName" in the address bar). But I still couldn't get all the way up to see a list of the server shares without receiving an error.

Other Google search terms for this are "The network is not present or not started." (it switched between that error and "the specified network provider name is invalid") and "System error 1222 has occurred. The network is not present or not started." (which I received when running "net use" from a command prompt).

  • To their credit, DiskInternals responded to my support ticket, saying "CBFS is a 3-rd party driver used in our products. It seems like there is indeed an error in our uninstall script, which doesn't invokes CBFS uninstallation correctly. Developers should fix it soon."
    – csrowell
    Feb 1 '19 at 15:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.