Currently I'm running Windows 7 x64 and usually I want all console tools to work with UTF-8 rather than with default code page 850.

Running chcp 65001 in the command prompt prior to use of any tools helps but is there any way to set is as default code page?


Changing HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage\OEMCP value to 65001 appear to make the system unable to boot in my case.

Proposed change of HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\Autorun to @chcp 65001>nul served just well for my purpose. (thanks to Ole_Brun)

  • 1
    Note the purposed solution could break Windows' find.exe (which would cause problems with Android SDK build): superuser.com/questions/176737/… – J Rao Jan 18 '15 at 5:24
  • 1
    Using the UTF-8 code-page also breaks the more command (it gives the misleading error message Not enough memory.) Opening the command-prompt with the /U switch does not help. – Synetech Mar 7 '16 at 22:00
  • 14
    The Windows console is riddled with bugs when the encoding is set to an unsupported multi-byte code page like 65001. Any software using the output counts of the Win32 WriteFile/ReadFile APIs will get the wrong results and consequently stuff build on that like the MSVCRT's implementation of the stdlib will produce mangled/repeated output and hang on input when confronted with non-ASCII. Until MS get around to fixing it — and it has been decades with no sign of that happening — globally changing console code page to 65001 is an extraordinarily bad idea. – bobince Oct 14 '16 at 8:51
  • 3
    Any use of the A versions of Windows functions is broken. All code needs to be ported to use the W versions. – Demi Apr 7 '17 at 14:42
  • 2
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage\OEMCP is used as fallback for non-unicode (non-utf) environments, obviously you try to force it to a 'unicode', as you see it is controversal by definition. Windows hangs probably because some system stuff on boot depends on non-unicode charset to work. – venimus Aug 23 '17 at 15:00

To change the codepage for the console only, do the following:

  1. Start -> Run -> regedit
  2. Go to [HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\Autorun]
  3. Change the value to @chcp 65001>nul

If Autorun is not present, you can add a New String

  • 1
    @Regent In the question, the registry value you mentioned that worked for you is @chcp 65001>nul, while in this accepted answer, it is chcp 65001. What are the differences between the two? – galacticninja Mar 16 '15 at 8:41
  • 9
    @galacticninja simply putting chcp 65001 will cause every opened command prompt to print 'Active code page: 65001' whilst @chcp 65001>nul will prevent any output. – Regent Mar 26 '15 at 15:51
  • 8
    Autorun is not present for me under Windows 8.1. – kleinfreund May 10 '15 at 9:09
  • 4
    @kleinfreund @Luke: if Autorun is not present, you can add a New String Value with the contents of @chcp 65001>nul – Dacto Oct 23 '18 at 20:45
  • 2
    @Dr.jacky Not sure exactly what they mean with dangerous. I've just answered the question of the OP. Whether you should do it or not is a different question. I believe there might be some issues with Python, so you may want to check that out before setting codepage to 65001 at least. – Nils Magne Lunde Dec 18 '18 at 6:59

Personally, I don't like changing the registry. This can cause a lot of problems. I created a batch file:

REM change CHCP to UTF-8
CHCP 65001

I saved at C:\Windows\System32 as switch.bat and created a link for cmd.exe on the Desktop.

In the properties of the cmd shortcut, changed the destination to: C:\Windows\System32\cmd.exe /k switch

Voilà, when I need to type in UTF-8, I use this link.

  • 9
    Note that it will print Active code page: 65001 to stdout. So if you are doing something like CHCP 65001 && mycommand.exe then you'll get the codepage printed out at the start. You need to CHCP 65001 >nul && mycommand.exe – frumbert Jun 12 '15 at 5:33
  • 1
    Why the CLS? :) – OMA Jan 24 at 1:30
  • 1
    @OMA it's "CLear Screen" to start with an empty console instead of seeing the message "Active code page: 65001". But you could also use >nul to get rid of the message (and the cls). – Matthieu Jun 7 at 9:44
  • 1
    @Matthieu : Yes, I know what CLS is for since I was little in the 80s ;-). The question was about what was the point in clearing the screen (that's why I wrote "Why the CLS?" and not "What's the CLS command for?". If it's just so the "Active code page" message is not visible, it's a bit of a crude way to do so (also, the user might not want to get rid of everything on the screen just because of changing a codepage). It's much better with the ">nul" approach you suggested. – OMA Jun 10 at 21:39
  • @OMA I thought so. I'm old too ;) – Matthieu Jun 11 at 9:24

Edit the Registry:

Windows Registry Editor Version 5.00

Then restart. With this fix, if you are using Consolas font, it seems to lock PowerShell into a small font size. cmd.exe still works fine. As a workaround, you can use Lucida Console, or I switched to Cascadia Mono:


  • The thing is, it only works for CMD, but not for console by itself. – AnrDaemon Sep 6 '19 at 9:10

In the 1809 build of Windows 10 I've managed to permanently solve this by going to the system's Language settings, selecting Administrative language settings, clicking Change system locale... and checking the Beta: Use Unicode UTF-8 for worldwide language support box and then restarting my pc.

This way it applies to all applications, even those ones that I don't start from a command prompt!
(Which was necessary for me, since I was trying to edit Agda code from Atom.)

  • 5
    Thanks, it solved my issue! – Jabba Feb 22 '20 at 10:09
  • 7
    This is the best and correct answer for modern Windows. – CAD97 Apr 1 '20 at 21:06
  • 1
    This certainly did the job for me. However, it had a nasty side-effect: QuickBooks (I used 2017 Professional) suddenly failed to recognize any of my account names, since they contain Unicode characters, and this setting really messed things up with that software. Just a heads-up... – Mike Allen Apr 15 '20 at 18:42
  • 2
    Hmm, the system must have got used to a stripped version of those names or something similar. Never thought this would break stuff while fixing other things, but I guess you can never make a change without messing up something. 🙃 (xkcd.com/1172) Thanks for the information, I hope that it doesn't happen to many other people, but at least now they can be prepared. – Isti115 Apr 15 '20 at 19:24

This can be done by creating a PowerShell profile and adding the command "chcp 65001 >$null" to it:

PS> Set-ExecutionPolicy RemoteSigned
PS> New-Item -Path $Profile -ItemType file -Force
PS> notepad $Profile

This doesn't require editing the registry and, unlike editing a shortcut, will work if PowerShell is started in a specific folder using the Windows Explorer context menu.

  • 1
    @PimpJuiceIT, no.. see the first line of this answer. – Dacto Dec 14 '18 at 17:21

The command to change the codepage is chcp <codepage>. Example: chcp 1252. You should type it in a Powershell window. To avoid the hassle of typing it everytime (if you always have to change the codepage), you may append it to the program's command line. To do so, follow these steps:

  1. Right-click the Powershell icon on Start menu and choose "More" > "Open file Location".
  2. Right-click the Powershell shortcut and select "Properties".
  3. Add the following to the end of the "Target" command line: -NoExit -Command "chcp 1252"

Be happy. Don't fuss with Windows Registry unless you have no other option.

  • This one worked perfectly for me. -NoExit -Command "chcp 1252 > null" also omits the message about the selected code page in the beginning. – CodeMonkey Aug 3 '18 at 8:53

If you're using ConEmu then:

  1. Open up Settings from the upper right menu
  2. Go to Startup -> Environment
  3. Add chcp 65001 on a new line.
  4. Click "Save Settings".
  5. Close ConEmu and re-open it

enter image description here


Open in Powershell through Explorer still didn't work for me even though I've tried enabling that Beta Unicode feature in the language settings.

However, I've just found this worked.


Manually changing the

From: https://www.zhihu.com/question/54724102

Not the answer you're looking for? Browse other questions tagged or ask your own question.