I've read a few posts about this problem before but it was either a slightly different problem than mine or people suggested what the problem could be, not a solution.

I am running Windows Vista 64bit (the worst possible combination, I know) on a HP HDX 16 laptop. It appears to be connected to the network, and the internet, but when I try to browse the web my browser complains that all pages "are not available", and any software I try to update, doesn't.

ipconfig says nothing is connected, though it shows I have an IP address.

I tried ipconfig/release+renew but it didn't work. After that I tried netsh winsock reset, rebooted the laptop and still nothing.

What course of action can I take now?

  • What do you mean ipconfig says nothing is connected? From CMD, can you ping IP addresses? Try ping, or just paste into a browser address bar. If you get Google.com, it's a DNS problem. – paradroid Apr 12 '11 at 17:35
  • I do get Google.com if I do that. So what does "DNS problem" mean? What should I do to resolve it? – OddCore Apr 12 '11 at 17:39

To set Google's DNS servers, open a CMD Prompt and paste these lines in, one at a time:

netsh int ipv4 add dnsservers "Local Area Connection" index=1
netsh int ipv4 add dnsservers "Local Area Connection" index=2

For wifi, try:

netsh int ipv4 add dnsservers "Wireless Network Connection" index=1
netsh int ipv4 add dnsservers "Wireless Network Connection" index=2

This is assuming that the network adaptors are using the default names, which you can find on the Networking tab of Task Manager.

For the GUI method, try this. Step 6 is the relevant part.

  • I am using WiFi, yes, sorry I forgot to mention. – OddCore Apr 12 '11 at 17:47
  • It gives me the error "The following command was not found: [what you told me to type]" for both commands. If I do netsh/? in the cmd the "add" command is there, which makes it more confusing. My version of windows is localized, Greek. would it make a difference for the network names? – OddCore Apr 12 '11 at 17:58
  • @OddCore: I don't know why that is happening. Just do it the GUI way then. You need to add the two IP address from above into the TCP/IP settings: windows.microsoft.com/en-US/windows-vista/… – paradroid Apr 12 '11 at 18:01
  • 1
    @OddCore - You probably have to run the cmd prompt as administrator. Right click on the shortcut and select "Run as administrator" – Nifle Apr 12 '11 at 18:04
  • @OddCore: Yes, I think the adaptor names will be different in Greek Windows. You will find them on the Networking tab of Task manager. – paradroid Apr 12 '11 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.