When I try to install the Bioshock2 game under windows 7 64-bit i get the following error-

"The version of this file is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher."

I try to run it in compatibility mode (as XP and admin) I get the same error. I don't understand why it is giving me this error because if it is 32bit program then it should just run like other 32 bit application I have. And I am sure Bioshock2 is not a 16bit game.

What can I do to run this program? It ran on Windows XP in the past.

  • 3
    The game might not be 16 bit, but the installer program very well could be. This is not uncommon in older games. – BBlake Apr 13 '11 at 11:58
  • is there any way i can run the installer – kaykay Apr 13 '11 at 12:07
  • how to identify whether the installer is 16 bit or not. – kaykay Apr 13 '11 at 12:10
  • This seems a bit like a question that would be better for Gaming.SE. – Wuffers Apr 13 '11 at 12:23
  • 2
    it is not just about gaming it is about any app that give the same error like i have pocket oxford dictionary which gave me the same error – kaykay Apr 13 '11 at 12:31

Bioshock is a 32-bit program and should run fine under Windows 7 64-bit, especially after you have set the compatibility mode to "Windows XP" and "Run this program as an administrator".

The only explanation is that your installation file or media is either damaged, or is not the real installer of Bioshock.

Other people have installed it on a similar configuration, although some did experience problems. An example is here. Most people have managed to fix these problems one way or another.

  • 1
    Question has been updated in that its bioshock 2. See my link in the question comments to microsoft/publisher saying its incompatible with 64bit... still... sure it should work – PriceChild Apr 13 '11 at 13:30
  • 1
    Microsoft doesn't like Bioshock 2 because the Steam Community feature conflicts with Microsoft's Games For Windows Live. You will have to disable it (if installed). Apart from this, I stay with my answer, since you should only get a warning while installing and have the option to continue, rather than a hard error. – harrymc Apr 13 '11 at 13:50
  • If it counts for anything, Bioshock 2 works fine on my 64-bit Win7 rig. – Nicholas Head Dec 19 '11 at 15:18
  • I had this same problem as @harrymc had and it was a pain in the backside to install. There's a great set of directions out there on how to install this correctly as there's other games that have this issue (GTA4 on PC comes to mind). My advice is to install the Microsoft Games for Windows live first, set up an account THEN install the game via steam. – Techie Joe Nov 1 '13 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.