7

This tutorial describes in detail how to setup a remote desktop from Windows to a Mac using putty tools and VNC.

However, my connection is immediately dropped after authentication. (i.e. tunneling and login works, but somehow the VNC session cannot be properly established or displayed). Following other hints I suspect graphics issues but haven't been able to resolve it so far.

Has anyone had this issue?

Or do you know a VNC Viewer that writes helpful log files?

  • What user are you connecting as? Anything useful in putty's logs (if not enabled do it plz) – drAlberT Aug 21 '09 at 8:54
  • Are you doing this over a LAN or over the Internet? – Barry Brown Aug 21 '09 at 9:43
1

I had a similar issue with a MAC -> PC connection (but without the PuTTY tools)

What I discovered is that the 'Server Type' needs to be implicitly set to the target system or set to 'Other' - Leaving it as 'Automatic' failed to work when connecting between disparate systems.

I can now connect from my iPhone -> PC or MacBook -> PC (and visa-versa) without issue.

  • This worked great for me – Toby Allen Sep 23 '09 at 19:06
  • Did you do this in the OSX VNC setup? – Michael Caron Dec 11 '09 at 16:35
2

I had the same issue using Remmina. After setting the Color depth to High color (16 bit), the connection works fine.

Full instructions:

1) Activate screen sharing on Mac OS X:

sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -on -configure -allowAccessFor -allUsers -configure -restart -agent -privs -all

2) Connect with remmina, using Mac username and password, and Color depth High color (16 bit)

3) Stop Screen Sharing with:

sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -deactivate -configure -access -off

Reference: https://apple.stackexchange.com/a/30239/57296 and https://apple.stackexchange.com/a/73919/57296

1

I discovered that it's a color issue. I used tightvnc leaving "use 8-bit color" unchecked and setting encoding to Hextile. Got through just fine over an SSH tunnel.

  • I don't know if it was a color issue for me, but TightVNC is working whereas RealVNC does not. Also, I am pleased with the logging capability fo TightVNC. – sage Apr 7 '12 at 20:44
0

I've had some trouble caused by Leopard's built-in VNC support, which apparently uses non-standard authentication that confuses VNC clients.

The solution was to disable OS X's built-in VNC (Screen Sharing in Preferences) and use Vine VNC instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.