When a PDF file is open in Firefox 4 in the Adobe Reader plugin, I am unable to scroll using the touchpad multi-touch gestures in other pages in the browser. Instead, the scrolling input is stolen by the Reader plugin; when I try to scroll on another page, the position in the PDF document changes in accordance with this scrolling input instead. This problem causes me to lose my place in the PDF file when I do other browsing, and I cannot scroll as easily in other pages because I must use the keyboard instead. However, I am able to scroll with a USB wireless mouse using the mouse wheel. Why does this happen, and what can I do to work around this problem?

My system is a custom-built HP Pavilion dv6z-3000 Select Edition laptop with Windows 7 Home Premium x64 Service Pack 1.

Edit: The problem may to be related to whether focus is on the plugin, but I'm still not sure why Adobe Reader would steal only scrolling input from the touchpad and not any input from any other device. Any suggestions?

4 Answers 4



We're looking at the bug here in this thread. If you happen to have this bug, comment with your OS version (Windows 7 64-bit, for example) and with who makes your touchpad.

Hopefully, we can debug this sooner rather than later. :)


My favorite solution is to disable the plugin so Acrobat files get downloaded and pop open a new Reader process, rather than sticking a fork in my web browser.

I'm still using FF3, where the necessary switches live in Tools -> Addons -> Plugins. Probably similar in FF4, though.

  • This is a good answer, but I'd like to view a PDF file in the browser before I save it. I'll see if there are any other suggestions; if not, I'll accept this answer.
    – bwDraco
    May 3, 2011 at 14:23

I'm not sure if this has been resolved or not, but I still have this issue. I believe it is directly related to the touchpad driver on certain HP laptops. This is why:

  1. I've had this happen to me on two consecutive HP laptops I've owned. It happens when trying to use the touchpad scrolling feature.
  2. I can't say I tested this on my old computer (HP laptop running Vista but I don't remember the model), but on this current computer (HP Pavilion dv6 running Windows 7) using a mouse scroll wheel seems to resolve this issue. I'm using an HP optical wireless mouse. Not sure what model.

This has persisted through multiple versions of Firefox.


Actually that's a bug in Firefox, as the PDF takes over the focus so you can scroll in it. After closing the PDF, it's not returning the focus, so you can't scroll anymore. I am actually looking into this issue for a lightbox we developed. One solution I've heard is to type about:config in your url bar, accept the warning message, search for general.autoScroll and set it to true. Not sure if that works for everyone but might be an option.

  • Insightful... I'll look into it.
    – bwDraco
    Jun 8, 2011 at 22:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .