I've found some instructions for this, but it seems the fsck options are outdated. Currently I am trying:

mke2fs -n /dev/sdc4  

then using the blocks listed in this:

fsck -y -b 163840 /dev/sdc4  

Actually, as I look at the fsck help, it would seem it should work, but when I run it, I get

invalid option -- b

why isnt this working?

1 Answer 1


Try e2fsck -y -b 163840 /dev/sdc4.

fsck is just a wrapper to the appropriate checker program for the filesystem. On my 10.04 box fsck does not take a -b option, but e2fsck does.

  • perfect, thanks man. if anyone else is doing this, it does have to be root Apr 17, 2011 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.