16

I have a laptop with a touch pad running Windows 7 for HP EliteBook 8730w. I find it really annoying that it takes clicks from the touch pad surface.

How can I disable clicks originating from the touch pad surface? I only want the surface to control mouse position and to use the explicit buttons for clicks.

1
  • 3
    that is driver dependent, we need to know exactly what laptop you have...
    – studiohack
    Apr 15 '11 at 4:22
7

For laptops in general:

Go to Control Panel, then Mouse, then click the Device Settings tab and you should see your touch pad as one of the devices. Make sure your touch pad is highlighted and click the Settings button and you will see Tapping as one of the choices.

From: http://www.techspot.com/vb/topic52389.html

4

If you are using a Synaptics touchpad, right-click on the touchpad icon in the notification area (system tray) and uncheck Tap to Click.

enter image description here

0
2

In the device settings, you can leave the touchstyk enabled, but disable its buttons. that only disables the upper touchpad buttons. you can disable the touchstyk as well. But, if you re enable it, it will automatically re enable the top buttons again. Interestingly, if you disable the touchstyk buttons, the tap-to-clik on the touchstyk is also disabled, meaning you can only point with the touchstyk. The touchpad with its lower buttons are equally available for independent enable/disable. Signed, equally annoyed by the top touchpad and touchstyck click actions while typing rapidly.

1

Consider to install TouchFreeze: Small utility that blocks touchpad while you are typing.

Annoyed when you are typing a document and accidentally the palm of your hand brushes the touchpad, changing the position of the cursor in your document or accidentally clicking on an option. TouchFreeze is simple utility for Windows to solve this problem. It automatically disables touchpad while you are typing text.

1

MOUSE Clicks TO MY ACTIVE WINDOW (Stops working sporadically)

Here is what I tried on my Linux Mint 18 [Mate] / Samsung RV510 laptop

[Based on the idea of disabling the suspected faulty Touchpad ]

[this gets a list of the input hardware installed]

smarts@Sams ~ $ xinput list

⎡ Virtual core pointer id =2 [master pointer (3)] ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)] ⎜ ↳ Microsoft Microsoft Mouse id=11 [slave pointer (2)] ⎜ ↳ ETPS/2 Elantech Touchpad id=15 [slave pointer (2)] ⎣ Virtual core keyboard id=3 [master keyboard (2)] ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)] ↳ Power Button id=6 [slave keyboard (3)] ↳ Video Bus id=7 [slave keyboard (3)] ↳ Power Button id=8 [slave keyboard (3)] ↳ Sleep Button id=9 [slave keyboard (3)] ↳ WebCam SCB-0355N id=10 [slave keyboard (3)] ↳ USB Keyboard id=12 [slave keyboard (3)] ↳ USB Keyboard id=13 [slave keyboard (3)] ↳ AT Translated Set 2 keyboard id=14 [slave keyboard (3)]

[Trying to disable the touchpad]

smarts@Sams ~ $ input set-prop 15 "Device Enabled" = 0

X Error of failed request: BadValue (integer parameter out of range for operation) Major opcode of failed request: 131 (XInputExtension) Minor opcode of failed request: 57 () Value in failed request: 0x88 Serial number of failed request: 20 Current serial number in output stream: 21

{It seems I will not be able to disable the touch pad this way!!!!}

Soln

[Linux Mint 18 [Mate] : Menu] / [Control centre] / [Hardware :mouse] / [Touch-pad] /

☐ Enable touch-pad (removed tick)

{ This effectively blocked the faulty touch pad's [spurious mouse movements] & [stealing control of main mouse click}

Great this worked!!!

ON WIN7

Try disabling it on your windows OS Image result for disabling touchpad on windows The Mouse Properties window will open; you might find a tab in that window where you can disable the touchpad.

Look for a touchpad software entry in the Start menu if you can't find it in the notification area or under Mouse Properties.
Click Start.
Expand Mice and other pointing devices.

More items... How to Disable Your Laptop Touchpad | PCWorld www.pcworld.com/article/241048/how_to_disable_your_laptop_touchpad.html

5
  • No! I rarely Joke. The sporadic input is the cause of the problem! Disabling the keypad or replacing it solves the problem. Replacing / Disabling is not OS specific! May 11 '17 at 22:27
  • Mint [Mate] combo is a very good replacement for the obsoleted Microsoft's Vista 32/64 OS. Since this year we now have full flash capabilities in Linux May 11 '17 at 22:33
  • Fair enough I added a win7 ending to do the question justice / and point the user in the right direction. May 11 '17 at 22:43
  • The user's problem exists on many OS's not only WIN. The root cause is the faulty machinery! May 11 '17 at 22:44
  • OP had already his answer and only disable click on touch pad is wanted
    – Sam
    May 12 '17 at 5:12
0

For some reason, HP EliteBook has default settings which make it virtually impossible to use the trackpad without accidentally clicking all the time. Fortunately, changing the settings will make the situation much better:

  1. In Windows, go to Control Panel
  2. Mouse
  3. Device Settings tab
  4. Select Synaptics LuxPad and click Settings
  5. Deselect Tapping

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.