I'm having a strange issue with my external hard drive. The external drive works perfectly under OSX and under Windows 7, yet, only if I connect it (power or USB) AFTER the BIOS has loaded (right up to the part where the bootloader starts doing its thing). If I leave the external drive connected when I bootup, it'll enter into an infinite reboot loop, unless I disconnect the drive.

With my previous computer, this didn't happen. I could happily leave my external drive connected with no issues at all.

I've already tried setting up the boot order to my Hard Disk Drives first, then my USB drive, but to no avail. This also happens when I leave an iPod or my Smartphone (Bold 9700) connected at boot-time.

I've also tried setting up a boot manager (Chameleon), with no luck.

Any pointers of what can I do so I can leave any USB mass storage device connected at boot-time?

If it helps, I have a Foxconn H55MX-S motherboard, and a WD 1TB Elements USB-HDD.

  • All I can say to you is i have a very similar issue, when i connect my mobile phone upon boot my laptop will not even reach POST it just freezes till i disconnect it. I think it's a bios related issue but i don't know. I was actually meaning too suggest trying it in a different USB port. I leave the external HDD connected too my desktop through a PCI USB 2.0 adapter card and that boots okay where as it used too cause boot issues – Arch Angel Apr 15 '11 at 14:03
  • @Arch Actually, I've tried that too - connected it through all 6 ports in the backside of the computer, and the 2 ports on the frontside - no luck. A PCI card that enables extra USB slots seems like a viable solution (since that wouldn't mess with the BIOS, I guess), but I don't wanna spend any more in extra stuff for my computer. – AeroCross Apr 15 '11 at 14:08
  • I full understand I only use this option because I had some spare PCI cards from old computers. This might sound stupid but have you tried a different cable it might effect how the power is distributed to the HDD during boot process – Arch Angel Apr 15 '11 at 14:10
  • @Arch Well, not really. It's the cable that came with my HDD. It should be noted that the HDD comes with it's own power supply (it's two cables, 1 for power, 1 for data), so, I have my doubts about it. – AeroCross Apr 15 '11 at 14:12
  • I guess your best option may be infact to get a usb hub so that you can connect the hdd to the hub seated on your desk to its easy to remove while booting. Thinking about it if you are not using USB to boot maybe you can remove it from your boot devices but you've probably tried that. – Arch Angel Apr 15 '11 at 14:15

In the BIOS setup set the USB emulation as floppy, this cured my issues with the reboot loop and Chimera. Although if I add or remove an external USB drive the settings get reset back to auto.


I vaguely remember having a similar problem. Changing the boot from usb device option (keeping only hdd as boot device) did the trick for me.

  • Sadly, that's the problem - the USB devices are in 4th+ position in the boot priority (since my computer has 3 hard drives, and there's a boot manager installed in EACH of them, making the problem even more weird). No matter what I try to do with boot device priorities, it seems that the USB device messes the boot at boot time. – AeroCross Apr 17 '11 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.