My ISP gave me a Thomson THG520 modem when I subscribed to their service. It has 2 links and USB and an Ethernet link. It worked fine with our 2 computers but for several weeks or so I experiencing that it only gives me IP address only on one interface that one that's first plugged into the computer.

If I reset the modem and plug in the USB I get an IP address immediately. If I unplug the USB and plug in the Ethernet cable I don't get an IP address. If I reset again the modem and plug in the Ethernet cable I get an IP address but not on the USB link after I unplug the modem.

What can be the problem?

EDIT: after entering the modem's administration I realized it's firmware was updated (probably my ISP did it.). Also I read about how this stuff works, there is an evidence that my ISP set the CPE limit to 1. (so it seem only one computer connected to the modem can get IP address while the other can't.). And this configuration is stored on the modem somewhere. Is there a way to view it somehow?

  • Your machine might not be requesting one, if you're in Windows have you tried "troubleshooting" the connection to get an IP? Apr 15, 2011 at 17:06
  • We have two computers. One is on the USB the another one is on the ethernet link. After the modem reset the first one that's turned on got an ip address and the other just won't get. I'm using linux and windows dual boot. None of the OS-es can get address.
    – Calmarius
    Apr 15, 2011 at 17:30
  • 1
    Since your ISP seems to have screwed up your device, you should call them, ask them to fix it, and invoice them for any time and costs incurred by you rectifying the problem. Unless of course what you're trying to do is against their terms of service. Apr 15, 2011 at 19:30
  • 1
    Are we talking about public IPs or private IPs? Is your modem in bridged or routed mode? using pppoe? What I suspect is that you are talking about public IPs and your ISP probably only has one assigned to your circuit, meaning if you don't NAT, you only get a single device connected at any time.
    – MaQleod
    May 31, 2011 at 6:51

1 Answer 1


Confirm with your ISP that this is supposed to work. If it's not supposed to work, then there's your answer. If it is supposed to work, let your ISP fix it, since they broke it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .