I have an HP Photosmart 7150 networked on a Win7 PC. I followed the below directions to set up the share on my Mac with SnowLeopard. My issue is that a file that is, say 700 kilobytes gets transmitted to the spooler as several megabytes. As a result when I print a file it runs through all of the paper in the tray. If there is enough paper loaded it will eventually print the file. Somewhere in the middle it will print several pages of garbage.

  1. Make sure your printer is on and connected to the USB port on the router.
  2. In OS X go to System Preferences.
  3. Click on Print & Fax.
  4. Click the lock (to unlock) to make changes. Enter your password if you need to.
  5. Click on the plus (+) sign at the left to add a printer.
  6. In Leopard/Snow Leopard click on the IP tab.
  7. In the Protocol drop down, select HP JetDirect - Socket.
  8. In the Address drop down, type the IP Address of your printer (
  9. Leave Queue blank.
    1. Give a descriptive name [Network Printer].
    2. Give a descriptive location.
    3. In the Print Using drop down either select your driver or choose the "select a driver to use" option.
    4. Choose the appropriate driver for your printer.
    5. Press OK and then click Add.

See if you can print a different file from the same program, a webpage, and a textedit page. Don't worry about spooling sizes. Even a single page in notepad under Windows itself can "register" as 1.5+ MB when spooled out to the printer. Your problem is likely:

An incorrect choice for the Macintosh's printer driver. A particular post-processing setting on the Printer Preferences is throwing off the HP at the other end of the wire. If the files are in PDF format, mismatched PDF output levels could be wrong (like Adobe software using PDF level 3 instead of 1 or 2.)

Save yourself sanity and troubleshooting time: just connect your printer and Mac once via USB and test printing again before you start making settings changes.

|improve this answer|||||
  • I had tried to print from a couple of different programs, Office2010, textedit, and a pdf with the same result. I have now followed your advice and plugged the printer directly into the Mac and when I try to set it up, the Mac doesn't see it. – dave Apr 19 '11 at 12:14
  • On a hunch I swapped the USB cable out. It then loaded up fine on the MAC I tested out Office and it printed fine. I believe it has loaded the same driver I had installed when I networked it. Where would I find post processing settings? – dave Apr 19 '11 at 18:40
  • It's odd that it's working directly but garbling when it goes over the network. I'm not sure how to help there, other asking you see if new drivers are out, and to post on the HP forums. By "Post processing" I meant "Printer features" below "Presets". There's many parts you can change. "Color settings" and other names came up on Google images. The choices depend on your program. Check "IP printer" in the Print Utility for LPD options. – Vlueboy Apr 19 '11 at 22:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.