Is there any way of adjusting the aspect ratio of movies I view in Windows Media Center on Windows 7 RTM x64? Any hidden features? Any brilliant light weight plugins?

Using Shark007 Codecs, and otherwise just default Media Center and Media Player.

I know I could reprocess the videos, but that would probably ruin the already bad quality. I also know I could use VLC media player, but I really would like to find a solution that works in Media Center, since VLC media player isn't especially Remote Control and media collection friendly...

Update: By the way, I know I can Ctrl+Drag an edge of the media center in window mode and change the aspect ratio of the player, but that doesn't do anything to the video.

up vote 4 down vote accepted

The Method for Windows Media Player 12, found in Windows7 Beta through RTM, is buried: Tools>Options>DevicesTab>Display>Properties. The horizontal slider controls the aspect ratio.

Is Windows Media Player 12 remote friendly?

As far as windows media center goes currently I'm at a loss. Ctrl+Dragging as you mentioned does change it between at least two modes (wide and square). But does it carry over to full screen, I cannot tell. Finicky environment, too few controls for my liking; although I do like some of its intent.

I did find a new way to the program. It does not like to be ctl+drug across multiple monitors, it blacks out until restart of the video. (Third option controls visible but won't redisplay the image.)

Sorry if this hasn't helped.

  • 1
    Hm, that aspect ratio slider control doesn't seem to do anything... Made the Circle thing as wide as I could, hit Apply and nothing changed. Then tried it the other way, hit Apply, still no change. The Ctrl+Dragging, as I mentioned, does change the AR of the window, but not of the video. – Svish Aug 29 '09 at 12:34

This should give you the break down of what your wanting to do, you may need a couple add on's for WMC to have all the tweaks needed

How to improve the Windows Media Center's video picture quality

The picture quality of many downloaded videos isn't very good, but you can correct this. When playing a DivX video, switch Media Center out of Media Only mode by using your mouse to put the application into windowed mode (click the middle icon when you move the mouse to the top right). You should see two new icons in the Notification Area (bottom left corner): a blue ffdshow audio decoder and a red ffdshow video decoder. Double-click on the audio icon first to set the correct audio settings. Place a check mark in the Mixer box and then click Mixer. Select the Output speakers configuration from the drop-down menu. For most PCs with surround sound, this should be 3/0/2 for five channels, but for 7.1 speakers select 3/2/2. If you have surround-sound speakers, also place a check mark in the LFE box to send the subwoofer its own signal. Next, click Dolby decoder and choose Apply Dolby Pro Logic II decoding to all stereo sources. This should upsample stereo soundtracks to use all of your speakers. Click OK.

Now double-click on the video icon. For every setting we mention here, make sure the Process whole image option is selected. Place a check mark in the Deinterlacing box and choose Cubic interpolation from the drop-down menu. This will deinterlace TV programmes so that they match your TV's progressive mode. Use the mouse to place a check mark in Postprocessing, and another in Picture Processing and adjust the sliders until you're satisfied with the picture's colour, brightness and contrast.

Because downloaded video can look disagreeable, place a check mark in the Blur&NR (blur and noise reduction) box. Setting Soften to 40 or less and Gradual denoise to 40 or less should help to reduce noise and produce a better image. The detail in a video can be improved by placing a check mark in the Sharpen box. Select Unsharp Mask and adjust the Strength bar until you're satisfied with it (25 should be good enough). To make sure the picture look as good as possible on a TV, you can force ffdshow to upscale video so that its screen resolution matches that of your TV. Place a check mark in Resize & aspect. Select Specify horizontal and vertical size, and enter the size of your display in the box below, such as 1,920x1,080 for 1080p TVs. The video maintains its aspect ratio by default, so old TV shows will have black bars down the side of the picture. If you don't want this, select No aspect ratio correction, click Apply and the image will fill the screen. You can now maximise Media Center and use it as normal.

I hesitate to suggest this because it seems too obvious, and maybe you are looking for more fine grained control over the AR, but as it hasn't even been addressed yet...

There are 4 pre-set Aspect Ratio adjustments under 'Zoom' (Press MORE on remote, or right-click on the video)

  1. Normal
  2. Stretch to remove black bars on sides
  3. Stretch to remove black bars on top and bottom
  4. Dynamaic stretch to maintain aspect ration in middle of screen
  • They are kind of the thing I am looking for yes, but more fine grained as you said. Problem is that those just options depend on my screen size. One of the videos I have are in a weird aspect ratio which is less wide than 4:3. And I need to stretch it out to 4:3. Number 3 kiiind of worked when I had MC in window mode and in the 4:3 format, but in fullscreen it is stretched all the way out to 16:9 or 16:10. – Svish Sep 2 '09 at 11:15

I'm not too familiar with Windows Media Center, but I used to use MediaPortal for my HTPC and could easily change all kinds of a/v settings during video playback. I set a specific button on my Harmony remote (which was setup to emulate a Windows Media Center remote) to scroll through various aspect ratio settings.

It may take a little time to set MediaPortal up, but I found the settings to be fairly intuitive and extremely robust. Plus it has a great forum community to help tweak the program to your every need. And after getting the proper codecs it plays anything and everything perfectly.

You could also look into XBMC and MythTV.

  • Interesting :) – Svish Sep 2 '09 at 11:25

In Windows Media Centre for Windows 7: If you have "USB Freeview TV Receiver" use the "Left-right arrow keys" and "ok" button on the IR Remote and you will find the Zoom factors to go from 4:3 to fill your 16:9 laptop screen. I'm guessing you could use your standard keyboard left-right arrow keys and Enter to achieve the same result.

Just a thought. VLC player is supposed to play bad quality videos quite well, and you said that your videos weren't very good. Supposed that you use the VLC player and get a wireless USB mouse to browse though channels. Anyway, the Wikipedia article says this:

In addition to these interfaces, it is possible to control VLC in different ways:

* Configurable hotkeys
* Mouse gestures
* *LIRC and infrared controllers*

Visit the wikipedia page

  • i don't think so ... "I also know I could use VLC media player, but I really would like to find a solution that works in Media Center" – Molly7244 Aug 29 '09 at 12:21
  • I have a wireless USB mouse, but I prefer to use the remote. Also controlling VLC from a distance is not an easy task. Media Center is made to be controlled from a distance, so the controls are easy and text, buttons, etc. are easy to see, read and hit. – Svish Aug 29 '09 at 12:35
  • Why are you so sure you want to use Windows Media Player – The Green Frog Aug 30 '09 at 7:50
  • I don't, I want to use Windows Media Center. And the reason is simply that Windows Media Center does not suck when used from a distance. VLC kind of does. Try navigating VLC with a wireless mouse on a 22-24" display from a distance of 3-5 metres. – Svish Aug 30 '09 at 14:55
  • Oh, I see what you mean. Thanks for your time – The Green Frog Aug 31 '09 at 19:09

In the start menu, right click on Media Center and select properties. Shortcut tab, in Target, add "/widescreen" to what is already there i.e. "%SystemRoot%\ehome\ehshell.exe /widescreen".

Reopen Media Center and it should load in 16:9.

  • That seems to be doing the same thing as ctrl+dragging the edge while in windowed mode. Which does nothing to the video itself, only the player. – Svish Aug 30 '09 at 14:53
  • 1
    can you try using vlc and see if the videos can be changed to have a diff. aspect ratio ? If the problem persists, it's the video which needs work .. – pratyk Aug 30 '09 at 17:07

I had an issue like that on my first Media Center PC. My problem was that the video card did not support the 1920x1080 resolution and the only lesser resolution that would work with the tv was 4:3 and not 16:9 causing all video to be stretched out. I ended up buying a new pc for the Media Center PC and the video card that came with it supported 1920x1080 and now everything looks great.

Is it possible that you are not running windows in 1920x1080, or that the resolution you are using is not the native resolution of the TV? If that's the case, the answer is a video card that does support the native resolution.

  • 1
    No, the resolution on my screen is correct. The problem is that the video Showing is in a wrong aspect ratio. It should be 4:3 but the image is narrower than that, so I need to stretch it back into 4:3. – Svish Sep 2 '09 at 11:25

I think an aspect ratio problem comes from screens that are not either 4:3 or 16:9

Maybe there should be a setting in W7 MC settings where you can dial in the screen V and H pixels. Or tell it to default to the Computer screen setup settings.

For example my screen is 1920 X 1200 this is neither std aspect.

Power DVD handles this nicely by using only 1080 vertical height and using the top and bottom black bars for control stuff if you move the mouse or remote. It would be nice if W7 media centre behaved this way.

  • 1
    The problem has nothing to do with screen aspect ratio. My screen is 16:10, but that has nothing to do with the aspect ratio of the video. They are two ratios that doesn't have anything to do with each other at all. If any media player (that works) will get black bars on top and bottom if screen is 16:10 and video is 16:9. Problem is when the video for example is 17:9, but should have been 16:9, meaning characters look squished et cetera. – Svish May 3 '10 at 12:48

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.