2

I want to make the window titles transparent but completely clear. I've tried changing the registry's DWORD HideBlur in HKCU\Software\Microsoft\Windows\DWM\ to 1 to remove it, but without success.

Here's everything inside that key:

"Composition"=dword:00000001
"CompositionPolicy"=dword:00000002
"ColorizationColor"=dword:1affffff
"ColorizationColorBalance"=dword:00000005
"ColorizationAfterglow"=dword:1affffff
"ColorizationAfterglowBalance"=dword:00000005
"ColorizationBlurBalance"=dword:0000005a
"ColorizationGlassReflectionIntensity"=dword:00000032
"ColorizationOpaqueBlend"=dword:00000000
"EnableAeroPeek"=dword:00000001
"AlwaysHibernateThumbnails"=dword:00000000
"LastDisqualifiedCompositionSignature"=dword:000c0000
"HideBlur"=dword:00000001

I've rebooted and logged off between making changes to the registry, but everything is still the same.

1
1

I had luck with this (feel free to buidl a .reg from it)

[HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM]
"ColorizationGlassReflectionIntensity"=dword:00000000
"ColorizationOpaqueBlend"=dword:00000000
"HideBlur"=dword:00000001
2
0

The feature to actually remove the blur and not just the colorization was only available in Windows 7 build 7127 for debugging purposes, and has been removed in RTM (build 7600) and later. Note that it only ever removed the blur around the window chrome, not behind the taskbar ("superbar") or start menu.

However, you can replace 2 DWM system files with ones from that build to make it work on any Windows 7 build. Of course, you do this at your own risk, which is why I will not provide any automated tools here, but outline the steps to take for informational purposes.

The important files are dwm.exe and uDWM.dll in the system directory.

  • Take ownership and grant yourself all rights on them.
  • Rename them to something like dwm.orig.exe and uDWM.orig.dll for backup reasons.
  • Move in the appropriate 32-bit (x86) or 64-bit (x64) files from this download (moderators, please remove the link and notify me if posting links to these files is not allowed).
  • Add the aforementioned HKCU\Software\Microsoft\Windows\DWM\HideBlur registry key and set it to 1.
  • Restart the DWM service (from the command line with net stop uxsms and net start uxsms or via services.msc).

Here's a screenshot with a Longhorn PDC'03-esque theme on a current Windows 7 ESU system: Screenshot demonstrating disabled blur

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.