I accidently unplugged my router and modem the other day and since then I cannot get a wireless connection on my MacBook. The router and modem are on and seemingly working properly as they are being picked up by other devices such as my phone. I have tried turning them off and have tried shutting down my MacBook. My MacBook is picking up wireless signals (my neighbours networks are showing) just not mine! Any advice?

5 Answers 5


1st Option

Try connecting directly to the router via an ethernet cable. Test connection. If internet connection works, but your wireless signal is still not found, then you might need to reset your router.

This might erase some special settings in the router 
by going back to the default settings. 

Try this after trying the 2nd option and it did NOT work and you are willing to reset your router

You can always erase and reset the entire router if need be. This depends on the brand, but usually you can

-Connect via ethernet

-Go to in a browser and enter the password if any or leave blank if router was reset to the defaults.

-Set your settings

2nd Option

First do follow the previous steps by unplugging your router/modem and deleting your previous wireless settings from your mac before proceeding.

-Easy erase settings by going to the Network preference page and clicking on Advanced at the bottom right. In the window, you should see saved Wi-fi's. Select your previous router SSID and click on (-).

This deletes your router as a recognized device and will not automatically connect.

-If you want to be thorough, delete the stored password in your Keychain


Should NOT be necessary as it does not seems to be a credentials issue.
Just a thought, keep in mind if a similar issue presents.


Keychain Access

Look up your router's name the "SSID"

Delete the store keychain (your password)


If for some reason your MacBook connects to the wireless router, but you are not getting internet connection go to your browser and type which is the usual default IP address for the router.

You should see a login page. This is good, your MacBook is connecting to the router.

If no wireless connection can be established then...

Try manually entering the name of your router's SSID and then typing your password by going to

System Preferences



'Join Other Network' (in "Network Name")...

And type the SSID of the router you connected to, type password and select security (WAP2 or which ever) if any.

Hopefully this will find your router's wireless which indeed seems it is being broadcasted since your other devices connect to it.


MacBook Pro supports 802.11n wifi wireless networking. There are other wifi protocols like 802.11b and 802.11g. MacBook Pro is compatible with these (b and g) as well. Wifi issues prop up when your router supports other frequency and your laptop is trying to catch other frequency.

If your router supports 802.11b/g and compatible with n then it means some communication problem may arise between your wifi router and your laptop. Best thing that can be done here is to tell your router that it should send signal (broadcast) only on 802.11n.

Go to your wifi router settings (you need to connect your router to your laptop through cable for this. You can consult wifi router help book for this) and Fix channel as 11 (11 from 802.11 is called channel) and bandwidth as 150Mbps. n means it will run on 150Mbps. (generally b means 54 Mbps and g means 65 Mbps). Save your setting and you are hopefully ready to run without any hassle.

PS: You can do the same setting if your wifi is not visible or your MacBook Pro doesn't detect your home wifi.


You probably have a closed (also called "hidden", or "non-broadcast SSID") network. Networks configured this way don't broadcast their names and don't show up on a normal wireless scan.

To join it, go to your Mac's AirPort menu, select "Other...", and enter the exact name of your network (case, punctuation, and spaces matter), its security type, and the password.

  • Thanks for the suggestion Spiff, but I used to be connected to the network and have not changed any settings since (that I can remember). The only possible change I have made is that the router was unplugged. Other devices in my house were not affected though and still automatically connected to the network when I plugged the router in.
    – Ali
    May 1, 2011 at 6:28
  • Nevertheless I have tried to join the network as you described and it says 'collection timed out'. Do you or anyone else have anymore suggestions???
    – Ali
    May 1, 2011 at 6:31

Try the old ISP help line standby:

  • Unplug/shutdown everything and wait about 30s
  • Plug the modem back in and wait 60s
  • Plug the router back in and wait 60s
  • Start the computer and see if it picks up

I would do this just to see if it's a passing glitch that can be resolved by reinitializing everything. If not we can move on to more advanced troubleshooting knowing it's not something simple.


Your MBA is still looking for old settings.

Delete the preferences and restart the MBA.

System files (network and wireless):

/Library/Preferences/SystemConfiguration/com.apple.network.identification.plist /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist

System Files (General configurations)


802.1x Profiles: ~/Library/Preferences/com.apple.eap.profiles.plist

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .