I'm trying to determine what's eating almost half of disk on my Windows 7 Lenovo laptop but haven't been able to determine what. I read some of the answers on this site but none of the causes seems to be the cause of my problem.

What I've done so far:

  • Checked Windows' System Restore points but only minimum use, either way I deleted around 2GB if usage from there
  • Used WinDirStat and it came back with a total of 71.3GB usage at the root level
  • C Drives properties says 135GB being used out of 138 GB total, ie, 135 GB - 71.3GB = 63.7GB missing somewhere
  • No "Unknown" files reported by WinDirStat
  • Windows Disk Management utility doesn't report any unused partitions or unclaimed space
  • chkdsk comes out clean
  • Windows disk cleanup tool doesn't report anything big, just small stuff in the lower MB range
  • Lenovo backup tool hasn't been used nor there is a folder for the backup images

Any idea on what to look at and/or do?

EDIT: some additional info...


Disk Properties

Windows Disk Management

  • 1
    If you don't mind losing your restore points, disable system restore, then re-check disk space, also Try this program, be sure to run it as Administrator....uderzo.it/main_products/space_sniffer
    – Moab
    Commented Apr 21, 2011 at 23:41
  • how big is the hard drive? also, how recent/old a model?
    – Journeyman Geek
    Commented Apr 21, 2011 at 23:42
  • 1
    Is this the problem? It's somebody else with a Lenovo laptop... apparently the Lenovo backup runs automatically even if you don't tell it to. If that was the problem, let us know and we can close this as a duplicate.
    – nhinkle
    Commented Apr 21, 2011 at 23:46
  • Hmm, perhaps you can also try some alternative to the great little tool WinDirStat? Another approach would be to e.g. use UnxUtil's or GnuWin's du port.
    – mousio
    Commented Apr 21, 2011 at 23:59
  • 1
    I used to use a program called Space Monger to check disk usage, but I'm not sure there's any reason it would work if WinDirStat doesn't. Might be worth a try though: sixty-five.cc/sm/v1x.php (there's a newer version, but you have to pay for it)
    – user55325
    Commented Apr 22, 2011 at 1:32

6 Answers 6


Well, I found what the problem was....

I installed SpaceSniffer and initially it gave me the same numbers as WinDirStat, but it also gave me some warnings about some directories it could not read, and among one of them was the Lenovo RRbackups backup directory that I thought it was not there since neither Windows Explorer nor WinDirStat showed.

So I ran the tool again but with Administrator privileges and voila, it found the big a... GB file inside the RRbackups directory that the Lenovo utility creates and that I couldn't see before. It turns out somebody ran the backup tool without me knowing.

I should have suspected that it was a permissions issue even though I was logged in with an account that is a member of the administrators group. Way to go Microsoft with Windows 7, an administrators group that doesn't have administrators privileges.... go figure...

Thanks all for the tips...

  • 5
    Welcome to 2006 when Microsoft released a security feature called UAC in Windows Vista (and every Microsoft OS since). It's a good thing. Educate yourself. Commented Apr 22, 2011 at 21:17
  • Exactly, Linux has been using a similar (although better implemented) feature for much longer.
    – MaQleod
    Commented Apr 23, 2011 at 17:18

Run WinDirStat in administrator mode (it's a right click option). Some files can't be seen without this.

My culprit was MSSQL log files. One of them was 170GB.


What works for me was lowering space for Previous versions of files (http://windows.microsoft.com/en-us/windows/previous-versions-files-faq#1TC=windows-7).

  1. Click Start Icon
  2. Left Click on "Computer" and click on Properties
  3. Click on "System Protection" on left side
  4. Click on Disk and "Configure"
  5. Lower your quota

I had a similar situation on a Windows 7 laptop where nearly 500 GB was "missing" on my system partition. The partition was full, but Windows Explorer was unable to detect the missing space, and the "windirstat" program simply showed a 500 GB "unknown" entry.

However, the TreeSize Free (Administrator) program (https://www.jam-software.com/treesize_free/) was able to show what the problem was, namely that someone had misconfigured the Cobian Backup program such that the source and destination directories were the same. As a consequence, it recursed until the partition filled up AND made nearly infinitely long directory paths that neither Windows Explorer nor windirstat were able to handle.

Perhaps needless to say, none of the Windows directory removal tools, including cmd rmdir, would work to remove this mess and it was with great difficulty that I finally managed to clean it up.

  • Handy to know, and you're probably sharing out of genuine helpfulness; but posting two identical answers (1) (2) might be mistaken for stealth promotion.
    – bertieb
    Commented Feb 27, 2017 at 19:48

Assuming that there's files hidden away from the system, it probably should show up in rootkitrevealer - while it won't tell you filesizes, this should get you started on working out where the rest of the space went.

Alternately, i'd suggest running a windirstat equivilent off a linux live cd of some sort to bypass any OS level hiding of free space, and have similar graphical tools.


We had a similar issue where a user's machine had somehow turned on 'offline files' and so in the C:\Windows\CSC\v2.0.6\namesapace[file server]\ directory there were 164GB of space. Running WDS as admin couldn't find it but after reading dozens of boards and seeing frequent votes for TreeSize, I gave it a shot. This allowed me to identify where the space was being consumed, but in order to get rid of it I needed to go to the CSC directory and take ownership of it. This took a little while but worked. Other suggestions that i tried prior to taking ownership include using the GUI to disable 'offline files' and create an entry in the registry to format the offline files database. Neither of those two items worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .