I have to do work between two spreadsheets and I need to view them side by side. I can't just open the workbooks in separate instances because I need to make use of features like paste formatting, and all of that goes away when the workbooks aren't in the same instance.

Is there anything I can do to get two windows open, each with a separate workbook, each maximized on a different monitor, and still have access to the advanced cut/paste features?

  • I found this (open excel files as new window) as a duplicate, but I tried the accepted answer from that problem and it didn't work for me, so I'm going to leave this open for the time being. – nhinkle Apr 22 '11 at 3:21
  • It's a different question, he doesn't want them to be in the same instance, I do. Big difference. I'm surprised that question doesn't have a solution like this: experts-exchange.com/Software/Office_Productivity/Office_Suites/… – Alain Apr 22 '11 at 3:47
  • Copy/cut/paste works across instances in Excel 2007; and then you can cut -> paste special in the second instance to get all of the subset/transpose/etc. features. I do that all the time. What specifically doesn't work for you? – Ken Paul Apr 26 '11 at 22:44
  • 3
    When you copy across instances, you lose the formulae. – Alain Apr 26 '11 at 22:58
  • 4
    Note: as of Excel 2013 Preview, this is fixed! Finally, in 2012, we can have multiple Excel windows at once ON MULTIPLE DISPLAYS! – nhinkle Nov 19 '12 at 6:38

I'm assuming you're extending your desktop onto both monitors?

Once you've done that, make sure Excel is NOT maximized and manually resize the Excel program window using the corner resizing anchors to cover both screens.

Then you can open both spreadsheets and go to View>>View Side by Side.

On Mac: >> Window >> Arrange All >> arrange vertically.

  • 14
    I was really hoping this wouldn't be the only suggestion. This one is painfully annoying because of the different monitor sizes, and the taskbar taking up real-estate on one monitor but not the other. It means I have to make the overall size shorter on both sides, and then I have to manually size each window within excel to try and take up as much room as is left. Is there really no way to get two separate windows launched? – Alain Apr 21 '11 at 14:30
  • 1
    To address your taskbar issue, you could auto-hide the taskbar or perhaps locate it on the side of your monitor to prevent any vertical differences it would otherwise cause. Right-click on the start menu and go to Properties to change these settings. – J Rose Apr 21 '11 at 14:41
  • 2
    I'm only willing to go to so much trouble ;) – Alain Apr 21 '11 at 17:45
  • If I were you, I'd look for a utility/.ahk script/etc. to dull the pain. I do sympathize, I run a portrait + landscape configuration at my workplace, and have had to deal with plenty of annoyances that result from it. – Arctiic Feb 5 '20 at 2:51

I have the same problem but I found this and it works great!

When you open multiple Microsoft Word documents, you are able to put one on your main monitor and one on your secondary monitor to compare, copy and paste from one document to another. However, if you open multiple spreadsheets from Excel, you can't do the same thing! This has annoyed me since 2007 when Microsoft introduced the functionality in Word but not in Excel.

Well, I found a way around it. Here is how.

  1. Open your first Excel spreadsheet. Place it on the monitor you wish to work with it.
  2. DO NOT open the second spreadsheet with the Excel program that is open. Instead, go to your Start Menu and open Excel from there. Then do a File >> Open and open your second spreadsheet.
  3. Place the second spreadsheet on the monitor you wish to view the spreadsheet.

As far as I can tell, since you're opening a second instance of Excel, you can place it wherever you wish.

  • 4
    From what I've read the OP doesn't want to open two instances. – slhck May 2 '13 at 11:11
  • This doesn't work if you want multiple views into the same file. – glenviewjeff Nov 12 '15 at 20:17
  • This should be the correct answer. The first, accepted answer does not provide the solution to the question that was asked. I'm not sure if there is a way to flag this secondarily as the correct answer. – ssaltman Nov 10 '16 at 15:09
  • Now what OP wanted... but was what I wanted. So thanks! – the_new_mr Feb 12 '19 at 14:00

There's a New Window feature in tab View, but it still opens in the same parent window, because Excel is an MDI application. So you'll still need to resize the parent window to cover both screens

excel new window


This seems to be fixed in Excel 2013, which changed to SDI only

excel 2013 new window


A coworker of mine accomplished this by using a piece of software called UltraMon. Instead of dragging the Excel application window across both desktops (which I agree, is annoying), you can right click the application in your taskbar and click "Maximize to Desktop."


In Excel 2010,

To display the two files side by side instead of on top of each other, you have to load the two files as two separate instances. To do this, you must open a new instance of Excel, then open/create a workbook.

Summarized steps as below.

  1. Open the first Excel file you need to access and put that on Monitor.
  2. Open a second instance of Excel on Monitor #2 by going to the Start Menu > Programs > Microsoft Office > Excel.
  3. Move this second instance of Excel to Monitor #2.
  4. Open or create a workbook from the second instance of Excel that’s now on Monitor #2.
  • 2
    From original question: "I can't just open the workbooks in separate instances because I need to make use of features like paste formatting, and all of that goes away when the workbooks aren't in the same instance." – Alain Oct 26 '15 at 11:21

Click on the Office button (upper left corner) → Excel options → Advanced → General → check "Ignore other applications that use Dynamic Data Exchange (DDE)" box → OK. Excel spreadsheets will now open as a new file each time.

Please note: checking "Ignore other applications that use Dynamic Data Exchange (DDE)" box will sometimes cause your spreadsheets save with data on them to open as blank or grey spreadsheets. You will have to uncheck "Ignore other applications that use Dynamic Data Exchange (DDE)" box to eliminate this problem. It's kind of a catch 22.

  • 4
    Again, this all excel documents being opened in a separate instance, which the question explains leads to a whole slew of other problems such as not being able to copy formulas or formatting between sheets. Please check other answers (especially down-voted ones) to avoid repeating their mistakes. – Alain Nov 19 '12 at 16:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.