10

I want to record a sound that comes from a program in my computer, directly from my sound card, not using a crappy microphone to record it!

I was able to do this easily on Windows XP by choosing "what u hear" (yes, it really had "u" in it!) device from the recording options.

But on Windows 7 there is no such option anywhere, and generally I don't understand the Windows 7 sound options at all.

NOTE: This must be Windows 7 sound settings specific. I want to fool the computer to think that my computer audio is the microphone audio, so if I "speak" on Skype, they would hear any song I play on my computer. Do not suggest Skype-specific programs either. I want this thing to work in EVERY program on my computer, just like it did on Windows XP.


I finally found the working driver: SB24_VTDRV_LB_1_04_0065A.exe

  • What sound card do you have? Under control panel, hardware and sound, select the Sound heading.. then in the subsequent window select the recording tab, do you have an item in the recording list called "Wave"? Try setting this to the default recording device, I think this should be equivalent to the XP "What u hear" option. – Jay_Booney Apr 22 '11 at 11:52
  • i cant see "wave" there, these are what i got in there: Microphone - High Definition Audio Device (no connection), Line In - High Definition Audio Device (no connection), Microphone - SB Live! 24bit (cannot be used at this moment), Line-In - SB Live! 24bit (default sound device), Auxiliary - SB Live! 24bit (cannot be used at this moment), S/PDIF-In - SB Live! 24bit (cannot be used at this moment), Microphone - USB Audio Device (ready). Sorry for translations my windows is not in english. – winuser Apr 22 '11 at 12:16
9

In my Windows 7, there is a "Stereo Mix" in recording devices. Just choose that as default recording device and/or "default communicating device"(I don't know the exact name; it's in the context menu). Then any program which uses this device will catch what you can hear through the speakers.

In Windows XP it should be the same name. However, it depends on your sound driver, as I haven't see any devices named "what u hear"... Just try to play a music and watch the levels of input of all available recording devices.

Sorry the text above is not well organized... but hope it can help you.

EDIT:

I just saw your last comment... Does Creative have a new driver for your SB Live! 24bit? It seems that your current driver don't have this function.

  • i cant find stereo mix. these are what i got in there: Microphone - High Definition Audio Device (no connection), Line In - High Definition Audio Device (no connection), Microphone - SB Live! 24bit (cannot be used at this moment), Line-In - SB Live! 24bit (default sound device), Auxiliary - SB Live! 24bit (cannot be used at this moment), S/PDIF-In - SB Live! 24bit (cannot be used at this moment), Microphone - USB Audio Device (ready). Sorry for translations my windows is not in english. – winuser Apr 22 '11 at 12:18
  • the only thing that makes the volume bar change in the sound settings is "speakers" and i tried to select the default sound listening device in the recording options to speakers, but when i record sound, it wont record my speakers... – winuser Apr 22 '11 at 12:21
  • you should watch the devices on "Recording" tab... – Mr.X Apr 22 '11 at 12:25
  • Play some music whilst you are in the Recording tab of the sounds. Does anything show the "volume" bar moving in there? – Jay_Booney Apr 22 '11 at 12:29
  • the devices on recording tab doesnt make volume bar change at all. only thing that moves is the "speakers" item in the playing devices. – winuser Apr 22 '11 at 12:52
3

Try this: go into your audio properties, choose the recording tab, then right-click in the white space within the box which show recording devices. From the context menu which appears, select show disabled devices hopefully, stereo mix will appear.

  • already tried that, no stereo mix device there – winuser Apr 22 '11 at 15:40
0

The devices available for recording depend entirely on the soundcard and its drivers. The list of devices and their names varies enormously. On an older XP PC I could record from "wave-out mix" but on a later PC there was no device available.

On one PC, I had to upgrade from Roxio EMC 10 to Roxio 2011 to gain the ability to record music playing on a media player. This added "Speaker" and "line-out" devices to the list of available inputs for recording.

An easy hack is to connect your line-out to line-in and make sure to mute line-in on the speaker control to avoid a feedback loop. I have done this via an external (old-school) audio-mixer but in principle, you can just do it with a stereo cable with 3.5mm plugs. Record from line-in.

0
  1. Go to Control Panel → Hardware and Sounds → "Manage audio devices"
  2. Go to the Recording tab and choose "Stereo mix"

Not the answer you're looking for? Browse other questions tagged or ask your own question.