19

I have a plasma TV attached to my Mac Pro. I use it maybe once a week, to watch movies. Rest of the time it just stays connected to my Mac. The problem is that Spaces in bird eye’s view always displays a box for the plasma, which makes my main display’s box too small.

Is there a way to disable the secondary display without actually unplugging it?

5

Sorry this happens to be a year later, but I was just looking for a way to disable my secondary display and came across SwitchResX. It has a taskbar menu item to quickly disable any connected monitors.

I'm not sure if this will solve your Spaces issue, but it might be worth a try.

| improve this answer | |
  • Ooops. I have found this SwitchResX some time ago and already have forgotten about my question here on SuperUser. Thanks for your answer. SwitchResX indeed is the solution that works. – Ilya Birman Aug 20 '10 at 8:05
  • As of today, this is now a commercial product invalidating the answer. – leye0 Feb 19 '14 at 3:33
  • 1
    I find that this keeps the monitor active just blacks out the screen. It doesn't actually turn off the monitors. – Andy May 2 '17 at 18:24
  • @Andy exactly, it also means that GPU still has to render the main screen, which makes my system slower overall when I connect to my 2 external monitors at home. It's really annoying. Though it still runs faster compared to just leaving it on – MuhsinFatih Dec 1 '19 at 6:01
14

Since SwitchResX is not free, I have developed a simple free alternative, that allows you to turn off a specific Monitor.

https://github.com/Eun/DisableMonitor/releases

| improve this answer | |
  • Is there a 10.8-compatible app for this? – yellow-saint Jul 15 '14 at 20:04
  • I'am not sure if it works on 10.8 just try it out. Tell me if it works for you. – Eun Jul 16 '14 at 7:11
  • The system tells me I cannot run the app as it is a 10.9+ app. – yellow-saint Jul 16 '14 at 22:39
  • 2
    Ok, I added a new Release for support 10.6+, please try this version. – Eun Jul 17 '14 at 9:05
  • 1
    @BradParks, sorry for necrocommenting, but it may be a good idea to clarify to people that may stumble on this answer in the future: that "this software may cause damage" report apparently is related to this github issue. And honestly (and as some comments on that issue also point out) I find it extremely unlikely that a piece of software would cause this kind of damage (fry a thunderbolt port). It's more likely to be a coincidence, specially considering there was only this one report. It's kind of baffling the maintainer put that on README. – Fernando Figueiredo Sep 28 '19 at 17:00
8
+100

The only thing I can come up with which worked for me was to turn on mirroring (in the monitor menu in your menu bar, or in the screen preferences pane) and then turn off the secondary display. Spaces will then only show one display.

When you want it back (for watching movies, etc.), turn on the display and turn off mirroring.

This solution feels very kludgy to me, so I'm hoping there's a better answer (like 3rd-party software or a hidden pref which can be set via Terminal). But it should suffice for the short term.

| improve this answer | |
  • 1
    My main display is 2560 at 1600, while plasma is 1920 at 1440, so if I enable mirroring, it will use the lowest for both. So this one does not work for me, unfortunately. – Ilya Birman Aug 22 '09 at 5:23
  • I haven't tried this one yet, but does just turning off the plasma work? – John Rudy Aug 22 '09 at 16:11
  • It does not, for me at least. – Ilya Birman Aug 23 '09 at 8:10
  • I'll keep an eye out for software that might be able to take care of this, but if no one else has an answer at this stage, I'm fearing we might be at the end of the rope on this one. :( – John Rudy Aug 24 '09 at 1:01
  • You can toggle it using an app, or command line tool too! – Brad Parks Apr 12 '18 at 11:48
1

I found a different approach which works for my use case - showing a single monitor when connecting remotely to a multi monitor setup using Screen sharing.

All you have to do is enable "Display Mirroring", and the mac will automatically make it so all apps that were on different monitors are now on the one monitor.

More info in this similar question on AskDifferent stack exchange

| improve this answer | |
-1

i'm dealing with the same issue

MBP 16" + 27" monitor on my desk, and the need to control it via remote desktop

Remote desktop is not easy to use with multiple monitor (you see only one at a time, you can't drag and drop between screens, you can't move windows between screens, etc)

Turning on miroring is a solution but i really would like to find a way to disable the external monitor

One solution, a weird one but i have no other solution at the moment, is to plug the monitor to a remote controlled electric plug, and to switch on/off this plug via an app wich can be scripted (a one clic solution)

It cost 5 to 10$ (or €) and a bit of work to make it "one-clic"

There can be some issue : the wifi need to be live, the plug need to work without bug, and some monitors need a physical press on their "power" button to wake-up

Maybe i'll try that one day

| improve this answer | |
New contributor
AlxV is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
-2

disconnect the second display and then click "detect displays" that did for me

| improve this answer | |
  • 1
    That will work, but it doesn't answer the question. The questioner is looking for a solution "without actually unplugging it". Since it's a Mac Pro, the external display connector is likely not very accessible. – Doug Harris Aug 19 '10 at 18:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.