in one of my previous questions I had trouble with my laptop reading some CD's so I eventually replaced the CD/DVD combo drive with a second-hand one from ebay. I researched the drive I had to make sure the model I purchased was very similar to the old one. They are the slimline IDE ATAPI types drives that just slot in and fortunately the new one fitted fine. It is a TSSTcorp TS-L632D.

Unfortunately I have noticed that the new drive often does not seem to spin up to anything like full speed when reading CD's and DVD ROM's. So while it's fast enough to watch a DVD, copying files takes much longer than it should. I ran a DVD drive diagnostic program called Opti Drive Control and it indicated that read speed was about 1.5 - 3x depending on the position being read. I've noticed that the drive momentarily spins up after the disk is inserted, but then slows down.

I get the same problem with most CD ripping programs. But strangely, Exact Audio Copy (EAC) seems to be able to get the drive to spin up properly and the speed is perfectly acceptable. The program accesses the drive in 'secure' mode where as most other programs don't and I think this could be a clue.

I have found that I do not get this problem with DVD-R disks, which is making me wonder if it could be a problem with the laser - as I understand it a different laser is used to read recordable disks.

The controller is set to use DMA and I have tried disabling the option and it just makes things worse. I have tried removing then adding the drive in the device manager and it made no difference. I looked in the event log for indications of controller errors but none are reported.

I have both Windows Vista and Ubuntu installed on the machine and both seem to have the same problem.

I have checked in the BIOS and there is an option for Ultra DMA for both the DVD drive and the hard drive but I cannot enable it - it just says something about contacting 'your supervisor' even if I log in with the supervisor password. Whether or not this option would make a difference I do not know.

It's a Zoostorm laptop, but about three years old so I'm not sure I would get much in the way of support from them. Does anyone have an idea what the problem could be? Or do you know of a way of diagnosing the problem: how can I be sure if the drive itself is faulty? It only came with 28 days warranty so I can't return it but I would be interested to know how feasible it would be to get it repaired.

Thanks in advance.

EDIT: I tried using a lens cleaner CD as suggested by some posts on the internet but it had no effect

EDIT: I was unable to update the firmware as it seems that there are lots of different versions of the drive and there is a risk of breaking it.


Although having changed the device, the driver may still be left-over from the previous incarnation. You might have a look if the manufacturer distributes a driver for this model (and I mean first the manufacturer of the drive, then that of the computer).

You might next try to delete the device and IDE channel :

  1. In Device Manager, expand first "DVD/CD ROM drives", right-click the right entry and choose Uninstall.
  2. Expand "IDE ATA/ATAPI controllers", double-click on IDE Channels until you find one that says in the tab Advanced Settings "Atapi Cdrom", exit the dialog, right-click on the entry and choose Uninstall.
  3. Reboot.

Before doing all this, take backups and a system restore point, just in case.

| improve this answer | |
  • 1
    As mentioned in my original question: - I have Windows Vista and Ubuntu and have already tried uninstalling the drive via device manager. I also mentioned it is a Zoostorm laptop but I doubt it is much help if I elaborate that it is an 8252D as it's not exactly a common model. – James P May 24 '11 at 14:47
  • Sorry, I missed the Vista/Ubuntu part. However, if no drivers are available except the Vista/Ubuntu ones, and forcing the OS to re-recognize the drive doesn't help, then the only option left is probably to check if the chipset driver is up to date. Otherwise my best advice would be to get a less-problematic drive (or computer). – harrymc May 24 '11 at 16:11

Whatever the issue was I was unable to get the drive working properly. I eventually replaced it and the new one seems to work fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.