I need to share a folder between windows 7 and mac os x on VMware.

How can this be done?

  • done with filezila
    – Maveňツ
    Commented Aug 30, 2018 at 6:21

4 Answers 4


You need to follow this procedure in order to share files between Windows 7 and Mac OS X on VMWare :

  1. Go in your virtual machine settings and select 'Options' tab.
  2. Click on 'Folder Sharing' and tick 'Always enabled'.
  3. Click on 'Add' button and select a folder you want to share.
  4. Confirm virtual machine settings.
  5. From 'System preferences' on Mac OS X, select 'Sharing'.
  6. Make sure that 'File Sharing' is enabled.
  7. From top menu bar, select 'Go' and 'Computer'.
  8. You will now see a folder named '/'. This is your shared folder between Windows 7 and Mac OS X.

Reference: https://web.archive.org/web/20150206003433/http://techsultan.com/share-folder-mac-os-x-windows-7-vmware/

  • 2
    I'd like to stress that this works when the virtual machine is Mac OS X running on a Windows host. Following the instructions allows the VM running Mac OS X to see the Windows shared directory/directories.
    – mbmast
    Commented Jan 6, 2016 at 7:25
  • 2
    Also, once the VMware shared folder is displayed you can drag it to Favorites section in the sidebar. Then it will be visible in all your applications.
    – mbmast
    Commented Jan 15, 2016 at 6:33
  • 9
    You can also go to Finder->Preferences->General Tab and select Connected Servers and you will see a VMWare Shared Folders icon in the desktop
    – Exlord
    Commented Jun 21, 2016 at 4:53
  • 1
    that was perfect Of course, we needed to restart the system once
    – Bashirpour
    Commented Aug 18, 2018 at 5:25
  • This answer has nothing to do with VMware Shared Folders. Instead, it shares Mac's drive via SMB. The first 4 steps are thus a red herring and are not needed. @Exlord's comment is the real solution. Commented Nov 3, 2018 at 5:33

Unlike other answers posted so far, this one explains how to connect the host and guest via VMware Shared Folders.

  • Install VMware Tools in the VM
    • If a security dialog pops up saying that a system extension was blocked, do as it says: go into security settings, allow the VMware system extension to run and when prompted for restart, choose to restart later.

vm menu tools vmware tools install screen


  • After finishing, the installation will restart the system

wizard end

  • Enable VMware Shared Folders for the VM

vm menu settings enter image description here

  • Press Add... and add a shared folder (pick any host folder that you have access to and any name)

add folder

  • Press Next and OK everywhere until all dialogues close

  • You should now have a "VMware Shared Folders" icon on desktop in which you will see the folder you've created. In the filesystem, it's a vmhgfs mount at /Volumes/VMware Shared Folders:

icon folder mount

  • If there's no icon, check in Finder->Preferences...->General if "Connected servers" is checked:

finder preferences

  • If you don't see either the icon or the mount, try uninstalling and reinstalling VMware Tools (this happened for me when an old version was originally installed), then disable and re-enable Shared Folders and reboot.
  • Awesome. helped me a lot! Thank you
    – Dror
    Commented Oct 14, 2019 at 19:37
  • 1
    In addition to the above steps I had to cd into the Shared Folder on macOS and execute open . to view the icon on Desktop. Commented Feb 14, 2021 at 12:46

You can enable sharing from within the OSX virtual machine System Preferences > Sharing > File Sharing. enter image description here

You can access this from within windows \\VMWARE VIRTUAL\User or by browsing the windows network.

By default yo may not be able to access some directories, you need to set the correct permissions for that within the virtual machine.If you want to be able to read and write into it something like chmod 777 Downloads/ should do the trick.

Ask away if you need any clarifications with this.


In VMware Fusion, select a virtual machine from the Virtual Machine Library (Cmd-Shift-L), press Cmd-E to open Virtual Machine » Settings… and select Sharing:

enter image description here

  • This looks like a recipe for when MacOS is the host OS. OP's case is the reverse. Commented Dec 8, 2018 at 19:10
  • @ivan_pozdeev Around the time I posted the answer, running OS X in a VM on a non Mac host was generally frowned upon, see e.g. meta.superuser.com/q/5478, so I probably chose this interpretation. Also, note that the question has been edited a few years ago to match my interpretation, VMware Fusion is their Mac (host) product. Looking at it now, it seems like a fairly low quality question, with something basic like that open to interpretation.
    – Daniel Beck
    Commented Dec 8, 2018 at 19:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .