I have a SanDisk Cruser drive that was formatted for a Mac and now I want to use it for a PC (and I don't have access to the Mac. What can I do?

4 Answers 4


Assuming Vista or 7 (this should work on XP, 8, 8.1, and 10, as well) and that the disk is not showing up under My Computer at all:

  1. Connect your disk.
  2. Run cmd as an Administrator.
  3. Run diskpart.exe. Use ? if you need help in this program.
  4. list disk
  5. Find the disk that corresponds to your USB disk. select disk n where n is the number of the disk. Confirm that you're using the right disk with detail disk.
  6. clean (Warning: This command erases the disk's partition information. Any data on the disk will no longer be accessible.)
  7. create partition primary. No size is needed if you want to use the whole disk
  8. active. Optional. Marks the partition as potentially bootable.
  9. format fs=fat32 quick. You can choose NTFS or exFAT instead of FAT32 if you want. (Note: Windows 10 limits FAT32 to 4GB. I recommend using exFAT instead, which is essentially a newer version of the same format.)
  10. assign. Assigns the disk a drive letter.
  11. exit to quit.

If you're still having problems with the disk after trying this, you might try omitting the quick from step 9 to do a full format. That will take a very long time and usually isn't necessary, but may help uncover physical damage to the disk.

In some cases you might need to re-initialize the disk. As above, this will destroy the data on the disk (or, rather, your ability to access it). To do that from diskpart.exe:

  1. list disk
  2. select disk n
  3. attributes disk clear readonly. This command will unset the read-only flag on the disk. You can see the current attributes with attributes disk or detail disk.
  4. online disk. Sets the device status to online if it's been disabled.
  5. convert mbr. Converts the disk to MBR format, which will work just fine for most disks. If you've got a USB disk larger than 2 terabytes, however, you'll want to use convert gpt instead.

I'm not sure if the above commands are all identical on older OSs (XP).

  • 2
    Didn't know about diskpart.exe . . . gotta try that now!
    – tooshel
    Apr 24, 2011 at 18:50
  • It worked! Is there a way to do that in the GUI? Is that the same as using "Disk Management"?
    – tooshel
    Apr 27, 2011 at 4:41
  • 3
    You can do a lot of it in Disk Management, but I'm used to diskpart now. Finding exactly what you have to click on to get the menu you want in Disk Management can be irritating, and I've found sometimes it doesn't display non-Windows formatted disks correctly. Diskpart just always seems to work.
    – Bacon Bits
    Apr 27, 2011 at 14:03
  • 3
    this is one of the best answers. It solved my problem with a USB flash drive that showed only 6 MB. Thank you!
    – ACV
    Jul 28, 2015 at 18:15
  • 1
    And we still say that Windows isn't for geeks!
    – wassimans
    May 30, 2017 at 9:26

Trying the other top answer, I received a "Windows was unable to complete the format" error. So for anyone getting the same, I found another solution.

  • Right click on "My Computer" and select "Manage".
  • Under "Storage" select "Disk Management".
  • In the lower right hand window, you should see the drive you're trying to format.
  • Right click on the volume and select the "Simple Volume Wizard".
  • Pick the format there and the wizard formats the disk without errors.

(On Windows 7) right click My Computer → Manage → Disk Management (under Storage). Identify your disk in the list, then right click on the volume and choose 'Format', then choose your preferred file system.

I had to delete previous volumes on that disk before I could do it - note that all data will be lost, so make sure you have backup or that you don't need it!

  • 1
    Note this does not always work: in some cases diskmgmt.msc will neither notice the existing partitions (just showing a fully unallocated drive) nor allow re/allocating them. In such cases, diskpart seems necessary; at least, it worked for me in 2 situations. Aug 10, 2015 at 8:51

Plug it into the PC. When it shows up under "My Computer" right-click on it and choose Format.

  • Tried that before I posted here and it does nothing.
    – tooshel
    Apr 24, 2011 at 18:50
  • 1
    I tried the "diskpart" advice from Bacon Bits and when I got to the "clean" command the format disk screen popped up and I got permission denied in diskpart. It was strange. But then the "windows format" failed anyway and I tried the "clean" again in diskpart and it worked. Right now it's formatting using diskpart.
    – tooshel
    Apr 24, 2011 at 18:54
  • You may get the permission denied error if another program is trying to access the drive, such as Explorer's disk format prompt. You can also get that error if you don't run as administrator, but in that case, it wouldn't have worked the second time either. Apr 27, 2015 at 13:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .