I am playing with my sexy new Ubuntu 10.04 server

I am trying to tunnel x11vnc through SSH to putty.

Steps I took (all from my Windows 7 client)

  • open putty (0.60)
  • Enter the server address under host name. The server is the DMZ computer on my home network. The client is behind NAT. The server has a dynamic DNS so I entered "xyz.dyndns.org" under host name. (yes, the real server is something other than "xyz" please don't go hack )
  • Under SSH--> Tunnels--> I enter 5900 under "source port" and "" under destination.
  • Click Add
  • Click Open
  • enter username and password
  • type "x11vnc -usepw" it confirms that the server is running and serving at 5900. I have also confirmed that there are no firewall rules blocking access to 5900 and one allowing access to everyody (no, I won't leave it like that for long).
  • open TightVNC viewer
  • type in

and it responds:

sorry loopback connections are not enabled

The error log at D:\Users\dreber\AppData\Roaming\TightVNC is blank.

Any thoughts?

  • try localhost:0 instead of May 26, 2012 at 4:30

6 Answers 6


If your installation of TightVNC was anything like mine, then the program TightVNC Service was also installed and is currently running in the background. TightVNC Service is a VNC server, which means your Windows 7 computer is running as a server when you want it to shut up and be a client!

All you need to do is look at your task bar for a little V icon and exit it. TightVNC Viewer can tell the difference between a real loopback and a SSH tunnel, so go ahead and try again after you've exited out of TightVNC Service. If it works, I would make sure TightVNC Service no longer runs on start-up.


This almost looks like some sort of safeguard built into the TightVNC viewer. Not allowing your to view localhost would prevent an infinite loop(to the point it dies), your desktop <- VNC view of your desktop <- VNC view of VNC view of your desktop <- VNC view of VNC of VNC ... crash. You might try another VNC client that wouldn't have that safe guard or you could change the source port to something other than 5900 to see if this might get around the restriction, if it really exists.


I was having the same problem and fortunately able to get it resolved. If you have installed the TightVNC Viewer with TightVNC Server then TightVNC service is running in background; and it is not allowing TightVNC Viewer to loop-back.

Here are steps you need to perform to get resolved:

  1. Press Ctrl+Shift+Esc simultaneously
    • Hopefully Windows Task Manager will appear
  2. Click on Services Tab in Task Manager Window
  3. Click on Services... (button at right bottom corner of task manager window)
    • Look for TightVNC Server
  4. Double Click OR right click on it and choose properties
  5. Click on Stop button to make this service stop

You can also make it disabled by clicking Startup type drop down and choose Disabled. Finally click Apply button to save your settings...


I ran into this exact issue, now some 12 years ago. Turns out there's a setting in TightVNC under "Access Control" where you have to enable loopback connections, and by default it was disabled. Ticking that box made it work for me.

Allow loopback connections


Have you tried setting your local IP(ie, or localhost:5900 ? (Also dig on the TightVNC preferences, if you did not already.)


First, one of the points of tunneling through SSH is that you don't have to open up the port to the world. The communication in practice is carried out over your SSH port.

Second, set the source port to 5901 and then connect to VNC server at localhost:1. It might be interfering with an existing VNC session on 5900 (=localhost:0) or something. Otherwise, it should not be a problem (I routinely do SSH forwarding 5900:localhost:5900 and it works, though there is no local VNC-server running).

You must log in to answer this question.