Windows XP 32bit. Working fine for a long time.

Recently, everything related to Java stopped working. Even the Java app in the Control Panel is not working anymore.

Whenever anything Java-related is launched, apparently nothing happens, no application appears to launch at all, except CPU usage goes to 100%. Investigating it, it turns out the javaw.exe process is at 100% CPU. And it stays like that forever.

I tried reinstalling Java, disabled the anti-virus, etc. Tried JavaRa (a tool to clean up old Java files) - nothing helped.

I can run "java -version" in the Command Prompt, and that one works fine, but it's no consolation.

I'm stumped.

  • 1
    What does that java -version say by the way. Also consider using sysinternals procexp to find out about the dlls that are used and whether they really belong to the newly installed JRE/JDK. Apr 26, 2011 at 1:49
  • 1
    Try logging in and running Java apps under a different user account. If it works, there's probably a file corruption issue associated with your user profile. Apr 26, 2011 at 2:46

1 Answer 1


It's because of VirtualBox.

This is a virtual machine running on VirtualBox. The latest VBox update broke Java. I filed a bug report and posted a warning on their forum.

They really need to get their act together. :(

  • It's great that you have answered this question yourself, but you should also accept the answer - click the tick mark to the left.
    – Bob
    Jul 15, 2012 at 1:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.