I bought this board today:

ASRock 880GMH/USB3 R2.0 And 2 DDR3 2GB RAMs (takeMS "TMS2GB364E082-139CM") Power = 300W.

The problem is that I get bluescreens (during installation of Windows 7) when I use 2 of the RAMs (4GB).

But if I install only one (doesn't matter which one) the system works, no crashes or bluescreens.

I tested them with memtest86 and here the same problem: the test crashes (computer reboot) when I use 2x RAMs (4 GB) after 10 seconds. And no problems or any errors are shown when used separately.

Any idea whats wrong?


Make sure you are placing it in the correct slots on your motherboard, it is usually the two same coloured slots. You can also refer to the ASRock Manual.

Also check to see your memory timings and speed are set correctly in the BIOS, this sometimes can cause problems.

And as a final thought, bad RAM. Make sure you do three test with memtest86:

  • With both sticks in
  • One stick in
  • The other stick in

This will let you know if the problem is with having both sticks in or just one of them, and will help you identify it.

And another thought would be for you to issue an RMA on the memory and get a new pair sent to you.

  • thanks. But I did the memtest86 and both rams are error free. The machine crashes only when they are together.I also tried to change the place with no luck... I will try to change different speeds in bios tomorrow. now I need some sleep ;) (GMT+1)
    – MilMike
    Apr 27 '11 at 20:44
  • GMT+0 22:46 is way to early for me lol. When you get this message get hold of the error message, that way I can further help you. Plus make sure you remove any overclocks on your system. Apr 27 '11 at 20:47
  • It works now, I just bought a RAM from different vendor (elixir) ;)
    – MilMike
    May 3 '11 at 7:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.