1

When you copy a VM in VMWare fusion - you simply copy the folder of VM files.

When you start up the copied one - VMWare will ask you if you copied it or moved - select copied.

Then inside the VM, you may not get eth0 networking (even though it has a new MAC address) - what is going on? (Specifically was Ubuntu server in this case).

1
  • Thanks for moving from SO to SU whoever did it ! Mucho appreciated. Apr 28 '11 at 2:11
3

The trick is to look in /etc/udev/rules.d/ and there will be files that remember what peripherals are connected - delete these (especially any ones to to with networking) and restart - and it should pick up the "new" adapter and mac address just fine.

Found answer buried here: http://communities.vmware.com/thread/46069

2
  • That's right. The server remembers the MAC address, and maps MAC address to the interface name. If the MAC address changes (it does when you copy a VM), the guest will create a new interface. Most modern Linux use a peristent udev rule for that, but notably RedHat (and derivatives) adds an ifcfg-ethX entry with the MAC address.
    – Keith
    Apr 28 '11 at 1:01
  • yes, exactly. This was ubuntu's latest LTS server. Is a bit annoying it does this - would be a common thing to do. Hopefully this helps people out. Apr 28 '11 at 2:11
0

I ran into a similar problem with Ubuntu 11 desktop VM, which I had earlier copied and upgraded from 10.10. The network was set to bridged mode, and it was working fine for several hours. Then it stopped working. First I suspected it might have been a problem with my DHCP server, because I could no longer log into my router. However, even after I rebooted my router, ifconfig refused to show an inet address. After trying many things, I decided to shutdown the VM, remove the network adapter from the settings, then re-add it. When I restarted the VM, the eth0 magically started to work again!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.