I have been trying to shutdown a remote XP machine but cannot get it to budge.

I did the following on the Windows box:

  • Ensured no firewall
  • Started Remote Registry Editing service
  • Shared a network drive (to enable file sharing?)
  • Created a user 'shutdown' specifically for shutting down
  • Added 'shutdown' to Administrators group
  • Added 'shutdown' to the list of allowed shutdown users in gpedit.msc

Here's what I have tried:

From Windows 7 box:

  • shutdown -m computer (Access denied message)
  • psshutdown -m computer (Access denied message)
  • runas /user:computer\shutdown "cmd /K shutdown -m computer (access denied)
  • runas /user:shutdown "cmd /K shutdown -m computer (access denied)

From Linux box:

  • net rpc shutdown -I computer -U user%password (says shutdown succeeded)
  • rpcclient -I x.x.x.x -c shutdown -U user (gives usage message)

Is there anyway to shut it down without resorting to telnet / ssh?


According to these links (1, 2, 3) you are most likely sending the psshutdown command as a guest user.

First, turn off simple file and printer sharing. Next, enable normal file and printer sharing.

Then instead of psshutdown, try:

psexec -u <xp_home_user> -p <password> \\xpMachine notepad

If Notepad opens, then that means psshutdown should work! Try:

psshutdown.exe \\xpMachine -t 10 -f -u Administrator -p password

I notice you said you had tried:

psshutdown -m computer 

However you should note that the psshutdown command requires a \\ and a password.

  • Thank you very much! All I had to do was turn off simple file and printer sharing. Also TIL how to enable the security tab on files :) – hamstar Apr 28 '11 at 2:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.