1

Every time I load Firefox up, it asks to be the default browser and even though I say yes it happens the next time I start Firefox. It also does the same if I tell it not to ask me. How can I fix this?

EDIT: I have Sophos AV, Windows 7, and Firefox 3.5.2.

1
  • what OS are you using?
    – cust0s
    Aug 22, 2009 at 11:08

7 Answers 7

4

You may want to look at "Setting Firefox as the default browser does not work".

Summary:

  • Windows XP. menu Start/Control Panel/Add or Remove Programs/Set Program Access and Defaults (left panel)/expand Custom (icon on the right)/"Choose a default Web browser"/Mozilla Firefox

  • Windows 7 and Vista. Control Panel/Programs/Set your Default Programs/ etc.

6

Check to see if Windows is setting your defaults:

For XP:

Start -> Control Panel -> Add or Remove Programs -> Set Program Access and Defaults -> Click Custom down arrow -> Select Firefox

For Vista:

Start -> Default Programs -> Set program access and computer defaults -> Click Custom down arrow -> Choose a default web browser and select Firefox

i copied echo's image, i hope he doesn't mind

related: How to change the default browser in Yahoo! Messenger

5

My Windows Firefox has the following sequence to stop checking for that.

  • Tools
    • Options
      • General tab
        • Uncheck "system Defaults" -- always check if default browser

However, if choose not to be asked when prompted, it should save that.

It could be possible that some other tool (AV? Anti-Spyware?) is preventing the change of default browser on your system.

Or, you do not have permissions to write this change (less likely but possible).

1
  • I am the admin on this PC and I have been using sophos AV for a while and it was fine then.
    – Jonno_FTW
    Aug 22, 2009 at 11:18
1

Click start then run and type "http://www.google.com" or another address and see what browser opens up.

If it is firefox, I am confused about this problem and if I was you, go in to tools > options and find the option to stop the check on system startup.

If it is another browser, see if you have installed any sort of anti spyware that prevents the default browser from being changed.

0

Try running Firefox as administrator and see if that helps.

Right click the icon, then select run as administrator.

0

see here: User.js file locks certain preferences.

http://kb.mozillazine.org/Preferences_not_saved

This is what solved the problem for me

1
  • 1
    Welcome to Super User! It would be nice to include the essential parts of the answer here, and provide the link only for future reference.
    – slhck
    Jul 11, 2011 at 11:03
0

None of the first provided advice in Google resolved the mentioned issue on my computer, but I found the solution.

The incorrect behavior obviously caused by migration from 32bit to 64bit version. We need just to replace the incorrect paths to the Firefox main executable image in the Windows registry:

1) Open Registry editor (regedit.exe);

2) Place focus on the root of registry database (My Computer);

3) Initiate text search (Ctrl+F). Specify "Parameter Value" flag only, and reset the rest flags.

4) Enter the next text to the search pattern field: "C:\ Program Files (x86)\Mozilla Firefox\firefox.exe" and press Search button to find first occurrence, all the next occurrences could be found by pressing consequentially F3 key.

5) Replace all incorrect occurrences with next string "C:\ Program Files\Mozilla Firefox\firefox.exe". This version doesn't contain "(x86)" string.

That is all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.