I had a HP laptop which died a couple of months ago. My boyfriend took the hard drive out of it, and made me an external hard drive.

Yesterday, a friend copied some pictures she had taken from her notebook to the external hard drive. When I tried to copy those pictures to my computer, the external hard drive no longer showed up! I still get an option to Safely Remove Hardware and eject media after I plug it in though.

I'm not sure what's wrong. The drive showed up fine on her notebook, just not my computer. How can I fix this?

| improve this question | | | | |
  • 1
    did it show up on her netbook before or after it didn't show up on your computer? Also, did the HDD work on the computer before? and finally, what does disk management say about it? – Journeyman Geek Apr 29 '11 at 23:45
  • is your friend a Mac and you are a PC? Serious question. – vinhboy Apr 30 '11 at 18:43

Edit: Providing you're running Windows.

It may be the driver letter isn't showing up. I've had this when the drive letters get conflicted.

That is, when you insert the drive, the letter E: (for example) is assigned to it. If your letter E: is being used by another drive, your USB drive won't appear as a drive.

It's a bug, as it should choose the next available letter, but sometimes it does go wrong.

How I normally access it is by trying the following:

Click Start > Run.

Enter a drive letter, for example, D: and click OK. This will load up whatever is associated with this drive letter.

enter image description here

C: will most likely be your OS, D: may be your DVD drive etc, but just go through the letters (up to about G: providing you don't have loads of drives plugged in) and see if you're then able to access the drive.

If this fails, your drive may be faulty. Also try viewing computer management in control panel to see if the drive is listed there.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy