I have a Kingston pendrive that i have formatted 20 times.

Whenever I try to make a bootable USB for installing Linux, I am not able to boot from it. I tried the same thing with another pendrive and it works fine.

Any ideas what the problem is?

migrated from stackoverflow.com May 2 '11 at 16:36

This question came from our site for professional and enthusiast programmers.

  • Not enough information to qualify as a Real Question. – Matt Ball May 2 '11 at 16:36
  • What did you use to create bootable USB? Did you use same thing? Your ubuntu version? – user May 2 '11 at 16:54
  • i have tried usb universal,unetbootin and many others.All of them failed – user65482 May 2 '11 at 17:32

Your USB drive has partition tables, and one of them is hidden from you which includes the USB software from the Manufacturer. The part of the drive that you have formatted over 20 times is the one that is not able to be booted from by the computer.

If you are using Linux, you can use gparted to completely delete all partitions and format the USB disk as a whole.

If you are using Windows this can be done under Disk Management by also deleting all the partitions and formatting the drive as a whole.

Please list your OS so we can be of further assistance.


For Windows use the following steps to format the entire drive.

  • Right click Computer in the Start Menu and select Manage
  • In the panel on the right, select Storage and open Disk Management
  • Select your USB device and right click each partition and select Delete Partition

After doing that, you should have a completely unallocated drive.

  • Right click on the unallocated part of it and select New Simple Volume
  • Select the drive letters etc.
  • Make sure to format the whole drive. Not any single partition.
  • i am using windows 7 – user65482 May 3 '11 at 9:52
  • there are no partition in the usb.when i open the disk management,i see only the usb pendrive – user65482 May 3 '11 at 16:39
  • It's one big partition? – paradd0x May 3 '11 at 17:32
  • yes It's one big partition – user65482 May 4 '11 at 16:23
  • Follow the above steps for formatting the whole drive and see if it helps. – paradd0x May 4 '11 at 17:11

I had the same problem with a Kingston Data Traveler stick (U3 version). Those U3 USB sticks are not simple USB sticks. They have their own partition table where they also include their own software.I tried a million times not just to format, but to re-partition the whole thing in order to install linux with no success at all. Other sticks without those features worked fine.

Just grab a plain usb stick without the U3 features and hope you will have more luck ;-)

  • I hate U3 Sticks with a passion - good thought. – tombull89 May 3 '11 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.