I'm having trouble setting up PuTTY with Ubuntu.

I'm trying to get line characters to work in aptitude as well as 256-color support, but can only get one or the other.

  • Ubuntu Config
    • Using 64-bit Ubuntu
    • Terminal type xterm-256color or putty-256color gives 256-color, but incorrect line characters.
    • Terminal type linux gives proper lines in aptitude, but only 16 colors.
  • PuTTY Config
    • Using font with Unicode characters. (DejaVu Sans Mono)
    • Received Data is assumed to be in UTF-8.
    • Set to use Unicode line drawing code points.

Output from locale:


The problem is that PuTTY in UTF-8 mode ignores1 VT100 "Alternate character set" commands, and ncurses attempts to use the "graphical" character set for drawing the GUI. (The box drawing characters are in the same positions as klmqx would normally be.)

export NCURSES_NO_UTF8_ACS=1 to your environment, it should fix the problem by telling ncurses to always use Unicode box drawing characters when a UTF-8 locale is selected.

1 There is a PuTTY wishlist entry for this, along with explanation why the current behavior is better.

Update (2018-05-12): It seems that this combination will be supported in PuTTY 0.71.

  • That's interesting. I just always used Lucida Console because the line drawing always just worked in UTF-8 mode. Now I can use much better fonts. Thanks. :) – Ariel May 3 '11 at 19:34
  • 8
    I just want to point out that running through a program that converts the alternate character set to UTF-8 also fixes the problem. I found this from the link you provided. The best example program is screen. – Swiss May 4 '11 at 6:35
  • 2
    not to dig up old posts, but KiTTY - a PuTTY fork - provides a checkbox to "Allow ACS line drawing in UTF" (new/current session settings->Window->Translation) which seems to work well with apps like aptitude. – aquafunk Sep 25 '16 at 17:44
  • 1
    @swiss: it is not screen which does the conversion, but ncurses. – Thomas Dickey Oct 1 '16 at 14:47
  • I am working in Putty and using zsh. I am having a similar problem as OP, in that in VIM, certain characters such as arrow in NERDtree are not being display. When I do "export NCURSES_NO_UTF8_ACS=1", and open VIM again, it doesnt do anything different. The arrows are still not displayed. Any idea whats going on? – alpha_989 Nov 11 '17 at 20:34

This is now implemented as an option in PuTTY git master.

Putty 0.71 ->

Category -> Window -> Translation -> tick "Enable VT100 line drawing even in UTF-8 mode"


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.