I recently upgraded from GNOME2 to GNOME3, and it's (mostly) been a smooth transition. One issue that has been bugging me, however, is the keyboard shortcuts, specifically, mapping certain keyboard shortcuts doesn't seem to work. I have several keyboard shortcuts mapped, but they do not work. For example:

  • Lock Screen: Mod4+L
  • Home Folder: Mod4+E
  • Run: Mod4+R (Works)
  • Run Terminal: Mod4+Enter (Works)

Why is it that some of these keyboard shortcuts work, but others don't? Any suggestions?



just ran into the answer actually. It's because the windows key is mapped to show the activities window. You need to disable that in order to get the shortcuts working. What worked for me was to go into region and languages, under Alt/Win key behavior click meta is mapped to left win key.

It seems that Linux immediately translates keys even when they are part of a key combination, so the left win is sent to the gnome bypassing the key combination.

  • Well, that certainly fixes part of it. I can no longer pull up activities when I hit the 'Win' key, but that doesn't matter much. Still bizarre that some keyboard shortcuts worked, and others didn't.
    – NT3RP
    May 5 '11 at 3:32
  • 2
    @Nicholas You can kind of pull up activities with Alt+F1. It's not perfectly equivalent, but it still has the "type to search" functionality.
    – Malabarba
    Jun 29 '11 at 14:03

Read this message: http://mail.gnome.org/archives/gnome-shell-list/2011-May/msg00291.html

I got my shortcuts to work doing what is described there (mapping Left Win key to Meta under 'Region and Languages'); I believe that I didn't need that in GNOME 2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.