I recently bought a Western Digital 2 TB drive to install on my system for additional storage and once it was installed my computer refused to boot.

Thinking that it might be a problem with the drive I shut down and removed the drive then everything worked fine. Now here is the kicker I switched the 2nd drive out for the new drive and then the computer boot right up (though it did not show that it existed).

The problem isn't the cables or ports either because I have changed those and verified they are working with the 2nd drive. Any help would be most appreciated.

  • OS: Windows Server 2008, Windows 7, Windows XP (selection doesn't matter at this point as I can't get to the boot loader)

  • MB: MSI K9A2 Platinum

  • CPU: AMD Phenom x4 9850

  • HDDS:

    • 1 Hitachi 500GB SATA

    • 1 Hitachi 1TB SATA

    • 1 Western Digital 2TB SATA

  • Power Supply: ABS 1100 Watt

  • 1
    @Draco - For clarity, you might want to specify in the question which drives are PATA (if any) and which are SATA. I was about to ask, but then saw the SATA tag. – Iszi May 4 '11 at 17:45
  • 2
    What does your BIOS say about the boot order of the drives? I'm guessing the 2TB is somehow taking precendence. – user3463 May 4 '11 at 17:51
  • have you tried booting with a linux live cd? and if so can you see all three drives? – mjrider May 4 '11 at 17:53
  • I have yet to try a live cd, but I have looked at the boot order of the drives and the 1st hard drive is the one that boots currently (I have modified the boot order a couple times to see) – Draco May 4 '11 at 17:56
  • 3
    did you try to change power supply? – kokbira May 4 '11 at 18:17

It's possible that the new drive is bad; you could try it in a separate computer to see if the same thing happens.

(There's at least one model of 2TB drives that have a history of being problematic; I'd hate for you to waste a lot of time troubleshooting everything else if the problem is with the drive itself.)

  • I was hoping to avoid it but I think I'll end up returning or exchanging it sometime this week to see if it is the drive as no one else has been able to shed more light on the issue then I already had. Also if the model your referring to is the western digital cavier green 2TB drives then that is what I have. I also still wonder why it interferes with boot operations only when the 2nd drive is plugged in. – Draco May 4 '11 at 19:32

Sounds like a BIOS problem.

Some things to try

  • Updating BIOS to the latest version
  • Turning ACHI on and off for SATA

Well the drive showing up might just be a situation of not being recognized. Perhaps boot with just the two drives and format your new drive.

As for not booting up with the third drive, are you sure your not plugging it into a RAID SATA spot on your motherboard, with the BIOS not expecting you to plug anything in there? Check your motherboard labelling and try swapping the arrangement of the drives.

It could also be a power issue, what is your power supply rated at?

and more importantly, what is the specific error the BIOS gives?

  • I never said anything about a BIOS error, the drive simply isn't detected by the BIOS at all. As for rating if you are referring to estimated usage its around 523 watts and the PSU provide 1100. Now as far as the SATA ports I have swapped the port with the working drives and a few empty slots and nothing changed. If my drive isn't recognized then I can't format a drive that the computer says doesn't exists. That being said I thank you for the input. – Draco May 4 '11 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.