When I try to print from my ThinkPad to a printer shared through a Windows 7 Homegroup hosted by a desktop computer, I often have to restart the Print Spooler service several times before the job will go through. In particular, this problem occurs when the desktop is in sleep mode when the print job is started and then brought out of sleep mode after the print job has been kicked off.

Both computers are running Windows 7 32-bit edition with the latest patches.

I have tried the following with no improvement:


You can try this on the PC hosting the printer:

  1. Click Start , click Run , type “Devmgmt.msc” (without quotes) in the search box and press enter. The Device Manager window opens.
  2. Expand Universal Serial Bus controllers.
  3. Right-click a USB Root Hub in the list, and then click Properties. The USB Root Hub Properties dialog box is displayed.
  4. Click the Power Management tab.
  5. Click to clear the Allow the computer to turn off this device to save power check box, and then click OK.
  6. Repeat steps 3 through 6 for each USB Root Hub in the list.
  7. On the Action menu, click Scan for hardware changes. Windows recognizes the new device.
  8. Now follow the same steps for the network adapter as well.
  • I already wrote that the desktop can detect and print to the printer. The issue is remote connectivity. – Zian Choy May 9 '11 at 17:53
  • @zian That's not at all what moab is saying... he is telling you these are options that stop the desktop from putting the printer to sleep you should probably read steps 1-6 and not skip directly to step 7... +1 btw moab this will probably fix his issue. – Supercereal May 9 '11 at 18:01
  • I actually tried all the steps and didn't skip directly to 7. The answer doesn't fix the problem. – Zian Choy May 9 '11 at 20:02
  • Do you have any 3rd party security software installed on either W7 PC? – Moab May 10 '11 at 14:59
  • No, I do not. <filler> – Zian Choy Mar 17 '12 at 3:02

Print spooler issues are usually caused by a faulty driver, and the best way to repair them is to completely reinstall the driver, as follows:

First delete the printer. Then select any other printer and click on the Printer Server Properties link that pops up. Click the Drivers tab, and delete any instances of the printer from the list. Now reinstall the driver, ideally from the CD or a downloaded driver, as it's possible the driver on the sharing PC is also corrupt.

To install from CD you may have to install it as a local printer first (select LPT1 as the port) and then connect to the share.

If reinstalling fixes the problem, I would recommend doing the same on the sharing PC as well.

  • This didn't fix the problem. – Zian Choy Jun 23 '12 at 19:55

The solution is to throw away the shared printer and buy a printer that can hook up to the network as an independent device complete with network sharing abilities.

  • 1
    While I agree with the sentiment, it would be nice if specific problem could be solved. – Daniel R Hicks Oct 22 '12 at 2:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.