Don't know what happened but this happens almost every time I boot. Never happened before a couple days ago and I haven't even done anything.

Computer powers up, GRUB (From fresh Ubuntu 11.04 install) loads, Windows 7 starts booting.

I configured msconfig to show the file it's currently loading when booting (The similar list you see when you boot into Safe Mode) and when it gets to C:\Windows\System32\DRIVERS\CLASSPNP.SYS, it takes a couple more seconds to load than other files if it doesn't hang.

Before the hang, my wireless LAN card is detected and then sound is activated (I can tell 'cause these lights on my laptop change to red when it's mute/disabled and blue when it's not). The hard drive makes the sound it makes when it's loading except the sound's constant (The HDD light's on. Not flashing like it usually does) meani. I can disable the touchpad but the keyboard doesn't work because the numlock light doesn't come on when I press numlock.

OS:     Windows 7 Professional x64 SP1
Laptop: HDX16-1155CA
CPU:    Core 2 Duo P7450 2.13 GHz
RAM:    4 GB DDR2
HDD:    320 GB Fujitsu something

Also, I've tried sfc /SCANNOW and it said that my system is fine

Never happened before, all I have is the mouse installed

Update: Now it restarts sometimes while loading CLASSPNP.SYS


Unplug whatever USB devices you have installed. You can also unplug internal devices as well. Plug them in one at a time and see what causes the hanging.

| improve this answer | |

This sounds like a classic hardware problem. It's either your RAM or the hard drive that's failing or just starting to. These problems can start to happen intermittently before they completely ruin your day. Running chkdsk on your c: drive should reveal any glaring filesystem errors and will attempt to fix them, but the underlying hardware issue could still persist.

I would recommend a tool like Hiren's BootCD, which contains the memory diagnostic tool Memtest86+ and a very powerful hard disk diagnostic tool called HDAT2. Look for Hiren's BootCD on your favourite bittorrent tracker as it is not distributed through the website I linked.

| improve this answer | |
  • I'll try running Memtest86 from GRUB – Alex May 5 '11 at 0:06
  • I ran a HDD utility from Fujitsu and Memtest86+ but I passed both – Alex May 5 '11 at 20:01

Ran the disk utility from Fujitsu and Memtest86+ and they found nothing.

Don't know what happened but the problem was randomly fixed one day. Think it was after some of Windows Update, don't remember. Didn't notice that it was fixed for a few days

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.